Bug 1006732 - Met "Unable to complete the registration process" error after accept terms when sign up.
Met "Unable to complete the registration process" error after accept terms wh...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 04:14 EDT by Tian Feng
Modified: 2015-05-14 21:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:50:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tian Feng 2013-09-11 04:14:24 EDT
Description of problem:
Register for a new account and cannot receive mail for registration. And the new account cannot be created. Also cannot reset password for an old account.

Version-Release number of selected component (if applicable):
INT(devenv_3772)
STG

How reproducible:
Always

Steps to Reproduce:
1. go to website
2. register a new account
3. reset password for an old account

Actual results:
Could not register and reset password successfully.

Expected results:
Could create a new account and reset password for an old account.

Additional info:
Comment 1 Jordan Liggitt 2013-09-11 09:31:01 EDT
Also recreatable in devenv with SSO enabled. No email is received on registration, so cannot log in.
Comment 2 Jordan Liggitt 2013-09-11 15:50:07 EDT
Being tracked with the streamline team. Emails are now being sent out but entitlements are not working once the new account is verified.
Comment 3 Yujie Zhang 2013-09-11 22:43:29 EDT
Tested on devenv_3776, INT(devenv_3775), and STG, can receive email when sign up or reset password, and met "Unable to complete the registration process" error after accepting terms, but the account is still generated and can login after that, site log is as following:

2013-09-11 22:32:49.659 [DEBUG] Streamline call (638.2ms) roles! /wapps/streamline/cloudVerify.html [ args: {}, code: 200, response: {"username"=>"yujzhang+devtestnewkkk@redhat.com", "roles"=>["simple_authenticated"]} ] (pid:10555)
2013-09-11 22:32:50.683 [ERROR] Streamline returned an unexpected response (pid:10555)
2013-09-11 22:32:50.687 [ERROR] --- !ruby/object:Net::HTTPInternalServerError
http_version: '1.1'
code: '500'
message: Internal Server Error
header:
  date:
  - Thu, 12 Sep 2013 02:32:49 GMT
  server:
  - Apache
  vary:
  - Host
  accept-ranges:
  - bytes
  content-length:
  - '12065'
  content-type:
  - text/html; charset=UTF-8
  strict-transport-security:
  - max-age=15768000, includeSubDomains
  connection:
  - close
body: ! "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\"\r\n        \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\">\r\n<html
  xmlns=\"http://www.w3.org/1999/xhtml\">\r\n<head>\r\n\t<title>redhat.com | The World's
  Open Source Leader</title>\r\n<link rel=\"SHORTCUT ICON\" href=\"/favicon.ico\"
  />\r\n<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/s/master.css\"
  />\r\n<link rel=\"stylesheet\" type=\"text/css\" media=\"print\" href=\"/s/print.css\"
  />\r\n\r\n\t\t<link href=\"/assets/global.css\" rel=\"stylesheet\" media=\"screen\"
  type=\"text/css\" />\r\n\t\t<script type=\"text/javascript\" src=\"/assets/js/jquery-1.4.2.min.js\"></script>\r\n\t\t<script
  type=\"text/javascript\" src=\"/assets/js/jquery-ui-1.8.4.custom.min.js\"></script>\r\n\r\n
  \   \t<script type=\"text/javascript\" src=\"/assets/js/jquery.selectbox-0.5.js\"></script>\r\n
  \   \t<script type=\"text/javascript\" src=\"/j/lib/jquery/plugins/jquery.cookie.js\"></script>\r\n
  \   \t<script type=\"text/javascript\" src=\"/j/lib/jquery/country-switch.js\"></script>\r\n
  \   \t<script type=\"text/javascript\" src=\"/assets/js/init.js\"></script>\r\n<style
  type=\"text/css\">\r\n#footer-nav ul.footer-nav-list li a, #footer-nav ul.footer-nav-list
  li {\r\n    color: #CCCCCC;\r\n    font-size: 11px;\r\n    text-decoration: none;\r\n
  \   white-space: nowrap;\r\n}\r\n</style>\r\n</head>\r\n\r\n\r\n<body id=\"mainzero\"
  class=\"en_US training ext\">\r\n\r\n\t<div id=\"container\">\r\n\t\t<div id=\"shell-top\">\r\n\r\n\t\t\t<div
  class=\"wrap\">\r\n\t\t\t\t<div id=\"header\">\r\n\t\t\t\t\t<div id=\"logo\"><a
  href=\"/\">Redhat</a></div>\r\n\t\t\t\r\n\t\t\t\t\t<div id=\"login-pre\">\r\n\t\t\t\t\t
  \   <a onmousedown=\"activateLogin()\">Log in</a>\r\n\t\t\t\t\t</div> <!-- / Login
  Pre-State  -->\r\n\t\t\t\r\n\t\t\t\t\t<div id=\"login-active\">\r\n\r\n\t\t\t\t\t\t<h2>Log
  in<span><a class=\"close-login\" onmousedown=\"deactivateLogin()\">X</a></span></h2>\r\n\t\t\t\t\t\t\t<form
  action=\"/wapps/sso/login.html\" method=\"post\">\r\n\t\t\t\t\t\t\t    <div>\r\n\t\t\t\t\t\t\t
  \   \t<input value=\"Username\" name=\"username\" class=\"search-field\" type=\"text\"/>\r\n\t\t\t\t\t\t\t
  \   \t<input value=\"Password\" name=\"password\" class=\"search-field\" type=\"password\"/>\r\n\t\t\t\t\t\t\t
  \   </div>\r\n\t\t\t\t\t\t\t    <p>     \r\n\t\t\t\t\t\t\t\t    <a href=\"/wapps/ugc/register.html\"
  class=\"arrow\">Register</a><br/>\r\n\r\n\t\t\t\t\t\t\t        <a href=\"/wapps/sso/lostPassword.html\"
  class=\"arrow\">Forgot Password</a>\r\n\t\t\t\t\t\t\t        <!--<input type=\"submit\"
  name=\"login-submit\" value=\"Submit\" class=\"login-submit\"/>-->\r\n\t\t\t\t\t\t\t
  \       <input type=\"hidden\" name=\"_flowId\" value=\"legacy-login-flow\" />\r\n\t\t\t\t\t\t\t
  \       <input type=\"hidden\" name=\"redirect\" value=\"http://www.redhat.com/\"
  />\r\n\t\t\t\t\t\t\t        <input type=\"hidden\" name=\"failureRedirect\" value=\"http://www.redhat.com/wapps/sso/login.html\"
  />\r\n\t\t\t\t\t\t\t        <input type=\"hidden\" name=\"_eventId_submit\" value=\"Log
  In\" />\r\n\t\t\t\t\t\t\t\t\t<input type=\"submit\" name=\"login-submit\" value=\"SUBMIT\"
  \ onClick=\"submitLogin()\"/>\r\n\t\t\t\t\t\t\t        <!-- <a href=\"#\" class=\"close-login\">Submit</a>
  -->\r\n\r\n\t\t\t\t\t\t\t    </p>\r\n\t\t\t\t\t\t\t\t<div>\r\n\t\t\t\t\t\t\t\t\t<input
  type=\"hidden\" name=\"asp_charset\" value=\"iso-8859-1\" /></div>\r\n\t\t\t\t\t\t\t</form>
  \               \r\n\t\t\t\t\t</div> <!-- / Login Active-State  -->\r\n\t\t\t\t\r\n\t\t\t\t\t<div
  id=\"masthead\">\r\n\t\t\t\t\t\t<div id=\"secondary-nav\" class=\"second-nav-rh\">\r\n\t\t\t\t\t\t\t
  <ul>\r\n\t\t\t\t\t\t\t \t<li class=\"first\"><span id=\"showCountryLang_a\" style=\"margin-right:10px;\"></span></li>\r\n\t\t\t\t\t\t\t
  \t<li><a href=\"https://access.redhat.com/home\">Customer Portal</a></li>\r\n\t\t\t\t\t\t\t
  \t<li><a href=\"/resourcelibrary/results\">Resource library</a></li>\r\n\t\t\t\t\t\t\t
  \t<li><a href=\"/partners/\">Find a partner</a></li>\r\n\t\t\t\t\t\t\t \t<li><a
  href=\"/wapps/store/catalog.html\">Buy online</a></li>\r\n\r\n\t\t\t\t\t\t\t \t<li><a
  href=\"/contact/sales\">Contact sales</a></li>\r\n\t\t\t\t\t\t\t </ul>\r\n\t\t\t\t\t\t
  \r\n\t\t\t\t\t\t \t <div id=\"search-wrap\">\r\n\t\t\t\t\t\t\t \t<div class=\"quick-links\">\r\n\t\t\t\t\t\t\t\t
  \   <form id=\"quick_links_form\" action=\"#\">\r\n\t\t\t\t\t\t\t\t        <select
  name=\"quick_links\" class=\"quick-links-select\">\r\n\t\t\t\t\t\t\t\t            <option
  value=\"\">I want to...</option>\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"https://access.redhat.com/downloads/\">Download
  evaluations</option>\r\n\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"/about/work\">Work
  at Red Hat</option>\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"https://access.redhat.com/wapps/support/protected/subscriptions.html\">Manage
  my subscriptions</option>\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"https://access.redhat.com/home\">Access
  Customer Portal</option>\r\n\t\t\t\t\t\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"/about/eventswebinars/\">Find
  events and webinars</option>\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"http://investors.redhat.com/\">Get
  investor information</option>\r\n\t\t\t\t\t\t\t\t\t\t\t<option value=\"/wapps/partner\">Log
  in to Partner Center</option>\r\n\r\n\t\t\t\t\t\t\t\t        </select>\r\n\t\t\t\t\t\t\t\t\t\t<div><input
  type=\"hidden\" name=\"asp_charset\" value=\"iso-8859-1\" /></div>\r\n\t\t\t\t\t\t\t\t\t</form>\r\n\t\t\t\t\t\t\t\t</div>\t
  \r\n\t\t\t\t\t\t\t \t<div class=\"search\">\r\n\t\t\t\t\t\t\t\t    <form id=\"search_form\"
  action=\"/search\">\r\n\t\t\t\t\t\t\t\t        <input value=\"Type to search\" name=\"q\"
  class=\"search-field\" type=\"text\" id=\"searchBox\" onfocus=\"if (this.value=='Type
  to search') this.value='';\" onblur=\"if (this.value=='') this.value='Type to search';\"
  />\r\n\t\t\t\t\t\t\t\t        <input type=\"submit\" name=\"search_submit\" value=\"\"
  class=\"search-submit\"/>\r\n\t\t\t\t\t\t\t\t        <input type=\"hidden\" value=\"lang_en\"
  name=\"lr\" />\r\n\r\n\t\t\t\t\t\t\t\t        <input type=\"hidden\" value=\"web-cms-r2-review-admin.usersys.redhat.com\"
  name=\"sitesearch\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"en\"
  name=\"hl\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"redhat\"
  name=\"site\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"Search\"
  name=\"btnG\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"default_frontend\"
  name=\"client\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"xml_no_dtd\"
  name=\"output\" />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"1\" name=\"proxyreload\"
  />\r\n\t\t\t\t\t\t\t\t\t    <input type=\"hidden\" value=\"1\" name=\"exclude_apps\"
  />\r\n\t\t\t\t\t\t\t\t    \t<div><input type=\"hidden\" name=\"asp_charset\" value=\"iso-8859-1\"
  /></div>\r\n\r\n\t\t\t\t\t\t\t\t\t</form>\r\n\t\t\t\t\t\t\t\t</div>\r\n\t\t\t\t\t\t\t</div>\r\n\t\t\t\t\t\t</div><!--
  /secondary-nav -->\r\n\t\t\t\t\t\t<div id=\"section-masthead\">\r\n\t\t\t\t\t\t\t\r\n\t\t\t\t
  \       </div>\t\r\n\t\t\t\t\t    <div id=\"primary-nav\">\r\n\t\t\t\t\t\t\t<ul
  class=\"primary-nav-list\">\r\n\t\t\t\t\t\t\t\t<li>\r\n\t\t\t\t\t\t\t\t\t<a href=\"/products/\"
  class=\"parent\">Products</a>\r\n\t\t\t\t\t\t\t\t</li>\r\n\t\t\t\t\t\t\t\t<li>\r\n\t\t\t\t\t\t\t\t\t<a
  href=\"/solutions/\" class=\"parent\">Solutions</a>\r\n\t\t\t\t\t\t\t\t</li>\r\n\t\t\t\t\t\t\t\t<li>\r\n\t\t\t\t\t\t\t\t\t<a
  href=\"/support/\" class=\"parent\">Support</a>\r\n\t\t\t\t\t\t\t\t</li>\r\n\t\t\t\t\t\t\t\t<li>\r\n\t\t\t\t\t\t\t\t\t<a
  href=\"/training/\" class=\"parent\">Training</a>\r\n\t\t\t\t\t\t\t\t</li>\t\t\t\t\r\n\t\t\t\t\t\t\t\t<li
  class=\"last\">\r\n\t\t\t\t\t\t\t\t\t<a href=\"/consulting/\" class=\"parent\">Consulting</a>\r\n\t\t\t\t\t\t\t\t</li>\t\r\n\t\t\t\t\t\t\t</ul>
  \              \r\n\t\t\t\t\t\t</div> <!-- / Primary Navigation -->\r\n\t\t\t\t\t\r\n\t\t\t\t\t</div><!--
  /masthead -->\r\n\r\n\t\t\t\t</div><!-- /header -->\r\n\t\t\t\r\n\t\t\t<div id=\"content\">\r\n\r\n<div
  id=\"contentWrap\">\r\n\r\n<div id=\"contentColLeft\">\r\n<!-- begin content -->
  \r\n\t\t<h1 style=\"padding-bottom:20px;\">Technical Problem (500)</h1> \r\n\t\t<p
  style=\"padding-bottom:20px;\">You've reached this page because of a technical problem
  that occurred while executing your last request. Our web engineers automatically
  receive an email alerting them of your difficulty and will address the issue promptly.
  We apologize for any inconvenience!</p>\r\n\t\t<p style=\"padding-bottom:20px;\">Please
  enter this problem in <a href=\"http://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Red%20Hat%20Web%20Site\">Bugzilla</a>
  if you continue to experience problems.</p>\r\n\t\t<p style=\"padding-bottom:60px;\">Return
  to the redhat.com <b><a href=\"http://www.redhat.com/\"><span style=\"color:#cc0000;\">home
  page</span></a></b>.</p>\r\n\r\n<!-- end content --> \r\n\r\n</div><!-- end contentColLeft
  -->\r\n\r\n</div><!-- end contentWrap -->\r\n</div><!-- /content -->\r\n\t\t</div><!--
  /wrap -->\r\n\t\t</div><!-- /shell-top -->\r\n\t\t\r\n\t\t<div id=\"shell-bottom\">\r\n\t\t\t<div
  class=\"wrap\">\r\n\t\t\t\t\t\r\n\t\t\t\t<div id=\"footer\">\r\n\t\t\t\t\r\n\t\t
  \   \t<!-- Call Out Boxes -->\r\n\t\t   \t\t<div class=\"call-out-boxes\">\r\n\t\t\t\t\t\r\n\t\t\t\t\t<div
  class=\"call-out-box\">\r\n\t\t\r\n\t\t\t\t\t    <div class=\"about\">\r\n\t\t\t\t\t
  \       <a href=\"/about/\">About Red Hat</a>\r\n\t\t\t\t\t    </div>\r\n\t\t\t\t\t</div>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<div
  class=\"call-out-box\">\r\n\t\t\t\t\t     <div class=\"partner\">\r\n\t\t\t\t\t
  \       <a href=\"/partners/\">Engage With Partners</a>\r\n\t\t\t\t\t    </div>\r\n\t\t\r\n\t\t\t\t\t</div>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<div
  class=\"call-out-box\">\r\n\t\t\t\t\t    <div class=\"community\">\r\n\t\t\t\t\t
  \       <a href=\"/community/\">Explore Communities</a>\r\n\t\t\t\t\t    </div>\r\n\t\t\t\t\t</div>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<div
  class=\"call-out-box last\">\r\n\t\t\t\t\t    <div class=\"myredhat\">\r\n\t\t\r\n\t\t\t\t\t
  \       <a href=\"https://access.redhat.com/home\">Access My Account</a>\r\n\t\t\t\t\t
  \   </div>\r\n\t\t\t\t\t</div>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<br class=\"clear\"/>
  \               \r\n\t\t\t\t\t</div> <!-- / Call Out Boxes -->\r\n\t\t\t\t\t                \r\n\t\t\t\t\t<div
  id=\"footer-nav\">\r\n\t\t\t\t\t                    \r\n\t\t\t\t\t<ul class=\"social-icons\">\r\n\t\t\t\t\t
  \   <li><span>Connect:</span></li>\r\n\t\t\t\t\t    <li><a href=\"http://www.twitter.com/redhatnews\"
  target=\"_blank\"><img src=\"/assets/images/social/twitter.png\" alt=\"Twitter\"></a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"http://www.facebook.com/redhatinc\" target=\"_blank\"><img src=\"/assets/images/social/facebook.png\"
  alt=\"Facebook\"></a></a></li>\r\n\t\t\t\t\t    <li><a href=\"http://www.youtube.com/user/RedHatVideos\"
  target=\"_blank\"><img src=\"/assets/images/social/youtube.png\" alt=\"YouTube\"></a></a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"http://www.linkedin.com/groups?home=&gid=2525539&trk=anet_ug_hm\"
  target=\"_blank\"><img src=\"/assets/images/social/linkedin.png\" alt=\"LinkedIn\"></a></a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"http://www.flickr.com/photos/49549965@N04/\" target=\"_blank\"><img
  title=\"Check out Red Hat photos on Flickr.\" alt=\"Flickr\" src=\"/assets/images/social/flickr.png\"/></a></li>\r\n\t\t\t\t\t</ul>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<ul
  class=\"footer-nav-list\">\r\n\t\t\t\t\t    <li>Copyright &copy;2013 Red Hat, Inc.</li>\r\n\t\t\t\t\t
  \   <li>|</li>\r\n\t\t\r\n\t\t\t\t\t    <li><a href=\"/footer/privacy-policy.html\">Privacy
  Policy</a></li>\r\n\t\t\t\t\t    <li><a href=\"/footer/terms-of-use.html\">Terms
  of Use</a></li>\r\n\t\t\t\t\t    <li><a href=\"/footer/patent-promise.html\">Patent
  Promise</a></li>\r\n\t\t\t\t\t    <li><a href=\"/about/work/\">Careers</a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"/about/mediarelations/trademark.html\">Trademark guidelines</a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"/about/\">About Red Hat</a></li>\r\n\t\t\t\t\t</ul>\r\n\t\t\t\t\t\r\n\t\t\t\t\t<ul
  class=\"footer-nav-list\">\r\n\t\t\t\t\t\t<li><a href=\"/contact/\">Contact Us</a></li>\r\n\t\t\t\t\t
  \   <li><a href=\"/footer/site-map.html\">Site Map</a></li>\r\n\t\t\t\t\t    <li><a
  href=\"/footer/faq.html\">FAQs</a></li>\r\n\t\t\t\t\t    <li><a href=\"/about/company/supplier.html\">Supplier
  requirements</a></li>\r\n\t\t\t\t\t    <li><a href=\"/about/\">Company</a></li>\r\n\t\t\t\t\t</ul>
  \               \r\n\t\t\t\t\t</div>  <!-- Legal Nav -->\r\n\t\t\r\n\t\t    \t\r\n\t\t\t\t</div><!--
  / Footer -->\r\n\t\t\t</div><!-- /wrap -->\r\n\t\t</div><!-- /shell-bottom -->\r\n\t\t</div><!--
  /container -->\r\n\t\t<script type=\"text/javascript\">\r\n\t\t\t\t\t//$(document).ready(function()
  {\r\n\t\t\t\t\t//\t$('.quick-links-select').selectbox( {\r\n\t\t\t\t\t//\t\tdebug
  : false\r\n\t\t\t\t\t//\t});\r\n\t\t\t\t\t//});\r\n\t\t</script>\r\n\r\n\t\t<!--
  SiteCatalyst code -->\r\n\t\t<div id=\"oTags\">\r\n\t\t\t<script type=\"text/javascript\"
  src=\"/j/s_code.js\"></script>\r\n\t\t\t<script type=\"text/javascript\"><!--\r\n\t\t\tvar
  errorType = \"500\";\r\n\t\t\tvar urlCopy = encodeURI(window.location.href);\r\n\t\t\ts.pageName
  = s.prop60 = \"rh | \" + errorType + \" | \" + urlCopy;\r\n\t\t\ts.server = \"redhat.com\";
  \r\n\t\t\ts.pageType = \"errorPage\";\r\n\t\t\ts.events = \"event60\";\r\n\t\t\ts.prop59
  = urlCopy.split(\".com\")[1].split(\"/\")[1];\r\n\t\t\ts.eVar60 = errorType;\r\n\t\t\t//--></script>\r\n\t\t\t<script
  type=\"text/javascript\" src=\"/j/rh_omni_footer.js\"></script>\r\n\t\t\t<script
  language=\"JavaScript\" type=\"text/javascript\"><!--\r\n\t\t\tif(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\\!-'+'-')\r\n\t\t\t//--></script><noscript><a
  href=\"http://www.omniture.com\" title=\"Web Analytics\"><img\r\n\t\t\tsrc=\"https://smtrcs.redhat.com/b/ss/redhatcom,redhatglobal/1/H.25.4--NS/0?[AQB]&cdp=3&[AQE]\"\r\n\t\t\theight=\"1\"
  width=\"1\" border=\"0\" alt=\"\" /></a></noscript><!--/DO NOT REMOVE/-->\r\n\t\t</div>\r\n\t\t<!--
  End SiteCatalyst code -->\r\n\r\n\t\t<!-- begin eloqua tracking -->\r\n\t\t<script
  type='text/javascript' language='JavaScript' src='/j/elqNow/elqCfg.js'></script>
  \r\n\t\t<script type='text/javascript' language='JavaScript' src='/j/elqNow/elqImg.js'></script>\r\n\t\t<!--
  end eloqua tracking -->\r\n\t</body>\r\n</html>\r\n"
read: true
socket: 
body_exist: true (pid:10555)
2013-09-11 22:32:50.687 [DEBUG] Streamline call (1027.1ms) entitled? /wapps/streamline/requestAccess.html [ args: {"solution"=>1}, code: 500, response: nil ] (pid:10555)
2013-09-11 22:32:50.687 [ERROR] Auto-request access for user yujzhang+devtestnewkkk@redhat.com failed, #<ActiveModel::Errors:0x00000001c53270> (pid:10555)
2013-09-11 22:32:50.687 [DEBUG] Streamline call (1027.1ms) entitled? /wapps/streamline/requestAccess.html [ args: {"solution"=>1}, code: 500, response: nil ] (pid:10555)
2013-09-11 22:32:50.687 [ERROR] Auto-request access for user yujzhang+devtestnewkkk@redhat.com failed, #<ActiveModel::Errors:0x00000001c53270> (pid:10555)
2013-09-11 22:32:50.690 [INFO ] Rendered access/error.html.haml within layouts/console (0.8ms) (pid:10555)
2013-09-11 22:32:50.693 [INFO ] Rendered /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-1.14.1/app/views/layouts/_head.html.haml (1.3ms) (pid:10555)
2013-09-11 22:32:50.697 [INFO ] Rendered layouts/console/_stylesheets.html.haml (3.5ms) (pid:10555)
2013-09-11 22:32:50.702 [INFO ] Rendered layouts/console/_header.html.haml (4.3ms) (pid:10555)
2013-09-11 22:32:50.704 [INFO ] Rendered layouts/_footer.html.haml (0.5ms) (pid:10555)
2013-09-11 22:32:50.705 [INFO ] Rendered layouts/console/_javascripts.html.haml (0.7ms) (pid:10555)
2013-09-11 22:32:50.705 [INFO ] Filter chain halted as :require_login rendered or redirected (pid:10555)
2013-09-11 22:32:50.705 [INFO ] Completed 200 OK in 2287ms (Views: 17.6ms | Streamline: 2266.0ms) (pid:10555)
Comment 4 Yujie Zhang 2013-09-11 22:55:09 EDT
I can use the account to login and create application from website, but met error when using it from rhc, details as following:

[root@dhcp-8-252 features]# rhc app create drupal php-5.3 mysql-5 cron --from-code=https://github.com/openshift/drupal-quickstart.git -l yujzhang+devtestnewkkk@redhat.com -p gaATKaXFFv --server ec2-23-20-136-97.compute-1.amazonaws.com
Using mysql-5.1 (MySQL Database 5.1) for 'mysql-5'
Using cron-1.4 (Cron 1.4) for 'cron'
Unable to complete the requested operation due to: In order to access and use
the OpenShift Online services you will need to accept the terms and conditions.
Visit the OpenShift Online console to accept the terms and conditions.
Reference ID: b12a322b5cb8f6841e3f279eedc446f4

Broker log is as following:

2013-09-11 22:49:51.348 [DEBUG] Current login = yujzhang+devtestnewkkk@redhat.com / authenticated for yujzhang+devtestnewkkk@redhat.com (pid:10028)
2013-09-11 22:49:51.349 [ERROR] Reference ID: 365699e2366cff569c78ba4d93bfd49a - In order to access and use the OpenShift Online services you will need to accept the terms and conditions.  Visit the OpenShift Online console to accept the terms and conditions
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-auth-streamline-1.9.1/lib/openshift/streamline_auth_service.rb:86:in `check_access'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-auth-streamline-1.9.1/lib/openshift/streamline_auth_service.rb:73:in `check_login'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-auth-streamline-1.9.1/lib/openshift/streamline_auth_service.rb:20:in `block in authenticate_request'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/http_authentication.rb:135:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/http_authentication.rb:135:in `authenticate'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/http_authentication.rb:125:in `authenticate_with_http_basic'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-auth-streamline-1.9.1/lib/openshift/streamline_auth_service.rb:18:in `authenticate_request'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:195:in `authenticate_request_via_service'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:150:in `block (2 levels) in authentication_types'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:146:in `each'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:146:in `block in authentication_types'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:52:in `each'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:52:in `each'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:52:in `find'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/authentication.rb:52:in `authenticate_user!'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:463:in `block in _run__3421374660321129062__process_action__1341736720799087812__callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_397'
  /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.14.6/lib/openshift/controller/action_log.rb:80:in `set_logged_request'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_397'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:403:in `_run__3421374660321129062__process_action__1341736720799087812__callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:17:in `process_action'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rescue.rb:29:in `process_action'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:121:in `process'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:45:in `process'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:203:in `dispatch'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:246:in `block in action'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `dispatch'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:36:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'
  /opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'
  /opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:600:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/mongo_mapper-0.11.1/lib/mongo_mapper/middleware/identity_map.rb:10:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/rack/mongoid/middleware/identity_map.rb:34:in `block in call'
  /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/unit_of_work.rb:39:in `unit_of_work'
  /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/rack/mongoid/middleware/identity_map.rb:34:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/sass-3.1.20/lib/sass/plugin/rack.rb:54:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/etag.rb:23:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/conditionalget.rb:25:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/head.rb:14:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/flash.rb:242:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:205:in `context'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:200:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/cookies.rb:339:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `_run__4044908666621086229__call__1280682003120012752__callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:26:in `call_app'
  /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:16:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/request_id.rb:22:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/methodoverride.rb:21:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/runtime.rb:17:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/lock.rb:15:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:245:in `fetch'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:185:in `lookup'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:66:in `call!'
  /opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/engine.rb:479:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/application.rb:223:in `call'
  /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `method_missing'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/request_handler.rb:97:in `process_request'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:521:in `accept_and_process_next_request'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:206:in `start_request_handler'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:79:in `block in spawn_application'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/utils.rb:470:in `safe_fork'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:64:in `spawn_application'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:264:in `spawn_rack_application'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:137:in `spawn_application'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
  /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.21/helper-scripts/passenger-spawn-server:102:in `<main>' (pid:10028)
2013-09-11 22:49:51.350 [DEBUG] FAILURE ACTION=LIST_DOMAIN USER_ID=523128b6c09c4f9243000001 LOGIN=yujzhang+devnewtestkkk@redhat.com DOMAIN= Unable to complete the requested operation due to: In order to access and use the OpenShift Online services you will need to accept the terms and conditions.  Visit the OpenShift Online console to accept the terms and conditions. (pid:10028)
2013-09-11 22:49:51.350 [DEBUG] FAILURE ACTION=LIST_DOMAIN USER_ID=523128b6c09c4f9243000001 LOGIN=yujzhang+devnewtestkkk@redhat.com DOMAIN= Unable to complete the requested operation due to: In order to access and use the OpenShift Online services you will need to accept the terms and conditions.  Visit the OpenShift Online console to accept the terms and conditions. (pid:10028)
2013-09-11 22:49:51.353 [INFO ] Completed 500 Internal Server Error in 522ms (Views: 0.6ms) (pid:10028)
Comment 5 Jordan Liggitt 2013-09-12 13:18:17 EDT
The stage streamline environment has been fixed, and new account registration works through the UI and with rhc
Comment 6 Tian Feng 2013-09-12 22:12:34 EDT
Test on INT and STG, and new account registration is executed successfully. But on devenv_stage_471, I can't register a new account successfully.
Comment 7 Tian Feng 2013-09-12 22:24:43 EDT
I feel so sorry for the result on devenv_stage_471, I forgot to enable sso. Now I can register successfully. So verify this bug, thank!

Note You need to log in before you can comment on or make changes to this bug.