Bug 1006734 - Exception in server.log caused that loading of designer freeze
Exception in server.log caused that loading of designer freeze
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 04:18 EDT by Sona Mala
Modified: 2014-08-06 16:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2013-09-11 04:18:01 EDT
Description of problem:
If I want to open process which is invalid or which contains unsupported element by Designer then exception in server.log is shown and loading of Designer freezes.

(this is realistic scenario because git repository has no protection. An user can write own BPMN definition and add it into repository)


Version-Release number of selected component (if applicable):
6.0.0 BPMS ER2

How reproducible:


Steps to Reproduce:
1. Add invalid BPMN2 definition into git repository.
2. Go to business central
3. Clone this repository
4. Open process

Actual results:
---------------
Loading of designer freezes, server.log shows some exception like:
  - Could not find BPMNDI information:
  - Event definition not supported: org.eclipse.bpmn2.impl.CancelEventDefinitionImpl@5d115595 

Common user does not know what happend. The user must have access to server.log if he want to know what happend.

Expected results:
-----------------
Stop loading of designer, shows some error page or alerts which describe actual problem.

My idea is that instead of Designer, a simple text editor is opened. This editor contains:
  - actual problem (highlighted line or simply write a message of exception into alert)
  - operation for writing, saving, deleting
  - source code of BPMN2 definition.

Now only way, how to delete or correct an invalid BPMN2 process, is an access to git repo.




Additional info:
Comment 1 Prakash Aradhya 2013-09-16 18:05:02 EDT
This is not necessarily a blocker.  But a valid scenario.

Designer freezing is not good. Can designer have some validation that the file is not valid and just bring up an error message ?

Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 2 Tihomir Surdilovic 2013-10-15 17:03:59 EDT
fixed
Comment 3 Marek Baluch 2013-11-26 11:25:06 EST
Reopening because it's not possible to delete the file in question any other way then using GIT.
Comment 4 Tihomir Surdilovic 2013-11-26 12:25:10 EST
You can delete this file from the save option in the designer toolbar. just click on it and select delete after opening it.
Comment 5 Marek Baluch 2013-11-26 13:08:37 EST
You cannot delete the process every time - see https://bugzilla.redhat.com/show_bug.cgi?id=1034783
Comment 6 Kris Verlaenen 2013-11-26 13:34:10 EST
Marek, we do agree that https://bugzilla.redhat.com/show_bug.cgi?id=1034783 is an issue, so this one is still open, and we'll try to fix asap.  But assuming you're not hit by this other bug (by which I still mean: assume you're loading a file with invalid content), do we still need to do something regarding this BZ?
Comment 7 Marek Baluch 2013-11-26 13:37:09 EST
I guess we don't. Marking as VERIFIED (on BPMS 6.0.0.ER5)

Note You need to log in before you can comment on or make changes to this bug.