Bug 1006735 - Generating default form when completing task fails with freemarker exception
Generating default form when completing task fails with freemarker exception
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Mauricio Salatino
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 04:19 EDT by Petr Široký
Modified: 2014-08-06 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with non rendered form (40.25 KB, image/png)
2013-09-11 04:23 EDT, Petr Široký
no flags Details
Server log with the freemarker exception (20.79 KB, text/x-log)
2013-09-11 04:24 EDT, Petr Široký
no flags Details
BPMN2 process that can be used to reproduce the issue (16.31 KB, application/xml)
2013-09-11 04:26 EDT, Petr Široký
no flags Details

  None (edit)
Description Petr Široký 2013-09-11 04:19:09 EDT
Description of problem:
Suppose there is a process with one or several human tasks (e.g. see the attached process). No forms were generated for those HTs so I would expect some default ones should be generated at runtime(?). However when the console is trying to display default form (when completing the task), the form is _not_ rendered and freemarker exception is thrown in the server log. See attached screenshot and server log. 


Version-Release number of selected component (if applicable):
6.0.0-ER2


Note: Not sure if form modeler is the right component, so feel free to change the component to more appropriate one.


How reproducible:
Always

Steps to Reproduce:
0. The user which will try complete the tasks has to be in group "engineering" in order to see the task.
1. Start kie-wb (business-central). Create new repo and new project. Add the attached process into the project.
2. Build & deploy the project and start the process.
3. Go to tasks view, claim the task and then try to complete it.


Actual results:
Form is not rendered and exception is thrown (in the server log).


Expected results:
Form is correctly generated and task can be completed.
Comment 2 Petr Široký 2013-09-11 04:23:34 EDT
Created attachment 796288 [details]
Screenshot with non rendered form
Comment 3 Petr Široký 2013-09-11 04:24:59 EDT
Created attachment 796289 [details]
Server log with the freemarker exception
Comment 4 Petr Široký 2013-09-11 04:26:05 EDT
Created attachment 796290 [details]
BPMN2 process that can be used to reproduce the issue
Comment 5 Kris Verlaenen 2013-09-16 13:49:45 EDT
The automatically generated form only supports String parameters and is only intended for demo purposes.  So it's unclear how much time we should spend on fixing this, as it's definitely recommended to create proper forms for your tasks / processes.
Comment 6 Prakash Aradhya 2013-09-16 18:12:02 EDT
It is expected that forms are generated.  If this is not the case, then it is an issue that needs to be fixed in Beta..
Comment 7 Mauricio Salatino 2013-09-19 15:44:11 EDT
Fixed on master: http://github.com/droolsjbpm/jbpm/commit/4d0af3fb9 
And backported to 6.0.x
Comment 11 Petr Široký 2013-10-17 12:03:44 EDT
Verified fixed in ER4. The attached process (three tasks with default forms rendered) can be successfully completed without any exceptions in the log.

Note You need to log in before you can comment on or make changes to this bug.