Bug 1006738 - aborts in Python during comparing operation
aborts in Python during comparing operation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libcomps (Show other bugs)
20
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Jindrich Luza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 04:26 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-20 06:19:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from gdb (33.59 KB, text/plain)
2013-09-11 04:26 EDT, Ales Kozumplik
no flags Details

  None (edit)
Description Ales Kozumplik 2013-09-11 04:26:18 EDT
Created attachment 796291 [details]
traceback from gdb

On my private branch I'm using libcomps-0.1.3-3 to implement DNF Payload support in Anaconda. I am seeing the python process being aborted after the python runtime tries to compare libcomps.GroupID objects. Attached is the full traceback.

Please fix this ASAP, the progress on DNF Payload is blocked by this.
Comment 1 Ales Kozumplik 2013-09-11 08:57:57 EDT
Here's a reproducer (it doesn't make sense because it was created by a bug in the payload code, yet the python bindings rule applies: no python programming error should cause sigsegvs/aborts):

import libcomps
from pykickstart.parser import Group

comps = libcomps.Comps()
comps.fromxml_f('/tmp/dnf.cache/default/fedora/repodata/16e49bf17cb730f0ec316dfb0c813241a955f545b0dac7c51dbb582ea6da14c9-comps-f20.xml')
gid = comps.environments[0].group_ids[0]
g = Group(gid)
g in [Group('2'), Group(gid)]
Comment 2 Fedora Update System 2013-09-12 06:07:34 EDT
libcomps-0.1.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libcomps-0.1.3-4.fc20
Comment 3 Fedora Update System 2013-09-12 12:27:57 EDT
Package libcomps-0.1.3-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libcomps-0.1.3-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16523/libcomps-0.1.3-4.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-09-16 06:38:34 EDT
libcomps-0.1.3-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libcomps-0.1.3-5.fc20

Note You need to log in before you can comment on or make changes to this bug.