Bug 1006757 - expose the security context used to run a HV
expose the security context used to run a HV
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Giuseppe Scrivano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 05:01 EDT by Giuseppe Scrivano
Modified: 2013-11-01 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 06:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuseppe Scrivano 2013-09-11 05:01:32 EDT
virt-manager has no way to known the user/group that run the HV
process without requiring the user to manually set it trough setup.py
or assuming "root" as default value.

This information should be exposed by libvirt trough the capabilities XML.
Comment 1 Giuseppe Scrivano 2013-11-01 06:24:00 EDT
feature accepted upstream:

https://www.redhat.com/archives/libvir-list/2013-October/msg00890.html

Note You need to log in before you can comment on or make changes to this bug.