Bug 1006796 - wkhtmltopdf page break can split lines
wkhtmltopdf page break can split lines
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
: 1122975 1192455 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 06:01 EDT by Tomas Capek
Modified: 2017-01-09 05:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-09 05:36:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Capek 2013-09-11 06:01:45 EDT
In a Publican-generated PDF book, when there is text on the very last line above the page footer, character tails and loops below the baseline are clipped and rendered at the top of the next page. 

Spotted at page 76 in Red_Hat_Network_Satellite-5.5-Installation_Guide-en-US.pdf and page 130 in Red_Hat_Enterprise_Virtualization-3.0-Evaluation_Guide-en-US.pdf
Comment 2 Jeff Fearn 2013-09-17 03:43:23 EDT
Please supply links and not just names.
Comment 4 HSS Product Manager 2013-09-18 01:27:41 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 5 Jeff Fearn 2013-09-18 19:40:32 EDT
This is a bug in webkit http://code.google.com/p/wkhtmltopdf/issues/detail?id=33 it will take a considerable amount of time to update wkhtmltopdf to use a newer webkit.
Comment 7 Jeff Fearn 2014-07-24 18:58:41 EDT
*** Bug 1122975 has been marked as a duplicate of this bug. ***
Comment 8 Lee Newson 2015-02-26 20:11:26 EST
*** Bug 1192455 has been marked as a duplicate of this bug. ***
Comment 9 Michele Baldessari 2015-04-19 13:49:49 EDT
Now that wkhtml has migrated to github, does anyone have a current correct issue link?

I get the issue when generating the Performance Co-Pilot handbooks. I see the
page breaks in the table of context (not sure if it is rendered as a table in html and hence is issue https://github.com/wkhtmltopdf/wkhtmltopdf/issues/2141)

Btw. Are there any workarounds for this?
Comment 10 Jeff Fearn 2015-04-19 20:27:27 EDT
(In reply to Michele Baldessari from comment #9)
> Now that wkhtml has migrated to github, does anyone have a current correct
> issue link?

I took a look and couldn't find it.

It looks like upstream has already started the QT5 port. https://github.com/wkhtmltopdf/wkhtmltopdf/blob/0.13/README.md#release-plan

> I get the issue when generating the Performance Co-Pilot handbooks. I see the
> page breaks in the table of context (not sure if it is rendered as a table
> in html and hence is issue
> https://github.com/wkhtmltopdf/wkhtmltopdf/issues/2141)

The TOC is generated using definition lists. So probably not the exact same thing.

> Btw. Are there any workarounds for this?

Unfortunately no :(
Comment 11 Jeff Fearn 2017-01-09 05:36:05 EST
Please open upstream bugs for PDF issues, there are no resources here to address them.

https://github.com/wkhtmltopdf/wkhtmltopdf/issues

Note You need to log in before you can comment on or make changes to this bug.