Bug 1006826 - deleting synced repo raises error
deleting synced repo raises error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
low Severity unspecified (vote)
: Unspecified
: --
Assigned To: Walden Raines
Ales Dujicek
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 06:49 EDT by Ales Dujicek
Modified: 2014-04-24 13:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-09-11 06:49:10 EDT
Description of problem:

deleting synced repository raises error:

> repo delete --org "org15" --name "repo15" --product "prod15"
wrong number of arguments (0 for 1)

Version-Release number of selected component (if applicable):
signo-katello-0.0.21-1.el6.noarch
katello-glue-elasticsearch-1.4.6-1.git.48.663056d.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.3-1.git.33.7c739e9.el6.noarch
katello-certs-tools-1.4.4-1.el6.noarch
katello-glue-candlepin-1.4.6-1.git.48.663056d.el6.noarch
katello-1.4.6-1.git.48.663056d.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.4.3-1.git.33.7c739e9.el6.noarch
katello-configure-1.4.5-1.el6.noarch
pulp-katello-plugins-0.2-1.el6.noarch
katello-glue-pulp-1.4.6-1.git.48.663056d.el6.noarch
katello-all-1.4.6-1.git.48.663056d.el6.noarch
katello-selinux-1.4.4-1.git.1.7abb02b.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-common-1.4.6-1.git.48.663056d.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. org create --name "org15"
2. provider create --org "org15" --name "prov15"
3. product create --org "org15" --name "prod15" --provider "prov15"
4. repo create --org "org15" --name "repo15" --product "prod15" --url "http://inecas.fedorapeople.org/fakerepos/zoo3/"
5. repo synchronize --org "org15" --name "repo15" --product "prod15"
6. repo delete --org "org15" --name "repo15" --product "prod15"

Actual results:
wrong number of arguments (0 for 1)

Expected results:


Additional info:
Comment 2 Justin Sherrill 2013-09-17 11:09:22 EDT
I am not able to reproduce this myself.  If you still are able to, could you provide a katello-debug?


Here's what happened when i ran it:

katello> repo delete --org "org15" --name "repo15" --product "prod15"
Deleted repository '39'
Comment 3 Walden Raines 2013-10-11 11:27:08 EDT
I cannot reproduce this either.  I am moving this to ON_QA to be retested.
Comment 4 Ales Dujicek 2013-10-15 04:09:17 EDT
katello> repo synchronize --org bz1006826 --product product  --name repo
Repo [ repo ] synchronized         
katello> repo delete --org bz1006826 --product product  --name repo
Deleted repository '356'

Verified.

ruby193-rubygem-foreman-katello-engine-0.0.14-5.el6sat.noarch
katello-configure-foreman-1.4.7-3.el6sat.noarch
katello-all-1.4.6-31.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.7-2.el6sat.noarch
katello-configure-foreman-proxy-1.4.7-3.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-cli-common-1.4.3-20.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-configure-1.4.7-3.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-foreman-all-1.4.6-31.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-20.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch

Sorry, I didn't noticed needinfo request (need better email filter).
Comment 5 Bryan Kearney 2014-04-24 13:08:20 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.