Bug 1006843 - qemu-kvm in des will quit when do migration with xbzrle=on and migrate_cache_size=0 in src
qemu-kvm in des will quit when do migration with xbzrle=on and migrate_cache_...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Windows
medium Severity medium
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 07:24 EDT by Jun Li
Modified: 2014-06-17 23:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:08:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun Li 2013-09-11 07:24:31 EDT
Description of problem:
When do migration to des host B with xbzrle=on and migrate_cache_size=0 inside src host A, the qemu-kvm inside des host B will quit.

Version-Release number of selected component (if applicable):
qemu-kvm-1.5.3-2.el7.x86_64
3.10.0-18.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot a guest on src host A, and then set xbzrle=on and migrate_cache_size=0.
2.Boot the same guest on des host B with listenning mode: -incoming tcp:0:5800
3.do migration from host A to host B.


Actual results:
(qemu) qemu: warning: error while loading state for instance 0x0 of device 'ram'
load of migration failed


Expected results:
When set migrate_cache_size=0 with xbzrle=on, qmp or qemu monitor should give a warning message: can not set migrate_cache_size=0. 
Or when xbzrle=on, can not set migrate_cache_size=0.

Additional info:
I also test xbzrle=off and migrate_cache_size=0, can do migration successfully.
Comment 2 Orit Wasserman 2014-02-11 10:36:59 EST

*** This bug has been marked as a duplicate of bug 1017096 ***
Comment 3 Jun Li 2014-02-11 21:31:38 EST
(In reply to Orit Wasserman from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 1017096 ***

Why set this bug as the duplicate of bug 1017096. This bug is filed before bug 1017096. When you have time, could you give some reason? Thx.

Best Regards,
Jun Li
Comment 4 Orit Wasserman 2014-02-12 02:43:32 EST
(In reply to Jun Li from comment #3)
> (In reply to Orit Wasserman from comment #2)
> > 
> > *** This bug has been marked as a duplicate of bug 1017096 ***
> 
> Why set this bug as the duplicate of bug 1017096. This bug is filed before
> bug 1017096. When you have time, could you give some reason? Thx.
> 
> Best Regards,
> Jun Li

Sorry didn't notice I will do it the other way.
Comment 5 Orit Wasserman 2014-02-12 02:43:41 EST
*** Bug 1017096 has been marked as a duplicate of this bug. ***
Comment 8 Ludek Smid 2014-06-13 07:08:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.