Bug 1006942 - SOA Installer should terminate eap process if the installation has failed
SOA Installer should terminate eap process if the installation has failed
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER3
: ---
Assigned To: Francisco Canas
Pavol Srna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 10:26 EDT by Pavol Srna
Modified: 2014-09-03 00:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (110.10 KB, image/png)
2013-09-11 10:26 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-09-11 10:26:16 EDT
Created attachment 796422 [details]
screenshot

Description of problem:

Soa Installer should terminate eap process if installation has failed.



Steps to Reproduce:
1. Choose server startup mode: "Standalone Mode"
2. go through the installation and on the shortcuts page hit on quit.


Actual results:
* some java processes are still running
* server is not reachable on localhost:8080
* cannot repeat the installation, because the process is holding port 9999.
Comment 2 Francisco Canas 2013-09-16 17:13:32 EDT
The Installer is now equipped with a server cleanup job that runs upon install completion, and also when the user quits/aborts the installation. The job checks the AS status and shuts it down if the install was aborted. This will occur before the installer housekeeper removes files, so that it doesn't leave a dangling server process.

The fix includes necessary changes to izpack's Housekeeping class:

Izpack change:
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=502b8ece3963b3e2efd7b42dcb7ff5b8566ef3ab

The installer branch with the fix:
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=shortlog;h=refs/heads/servercleanupfix

Commits from merge with SOA6:
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=e84360b04f401cb688741c5aa551cb6e26de438c
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=5e46bdf164c9adc3308ec6d8c44de546044318ed
Comment 6 Pavol Srna 2013-10-23 05:43:04 EDT
Verified in ER6 build.

Note You need to log in before you can comment on or make changes to this bug.