Bug 1006946 - [engine-backend] [external-provider] there should be a timeout failure when engine is unable to refresh images list of a glance storage domain
[engine-backend] [external-provider] there should be a timeout failure when e...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: nobody nobody
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 10:33 EDT by Elad
Modified: 2016-02-10 11:34 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 08:01:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshot (169.89 KB, application/x-gzip)
2013-09-11 10:33 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-09-11 10:33:46 EDT
Created attachment 796424 [details]
logs and screenshot

Description of problem:
When engine is unable to refresh and get images list of a glance storage domain, it should fail GetImagesListQuery after a few minutes.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.19.master.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. add a glance images external provider to RHEVM
2. change the password in OpenStack so engine will fail to connect and get the images list.

Actual results:
There is no failure by engine, it keeps trying to refresh the list forever

Expected results:
Engine should fail the action after a certain amount of time


Additional info:
logs and screenshot
Comment 1 Ayal Baron 2013-09-15 07:29:36 EDT
(In reply to Elad from comment #0)
> Created attachment 796424 [details]
> logs and screenshot
> 
> Description of problem:
> When engine is unable to refresh and get images list of a glance storage
> domain, it should fail GetImagesListQuery after a few minutes.
> 
> Version-Release number of selected component (if applicable):
> rhevm-3.3.0-0.19.master.el6ev.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. add a glance images external provider to RHEVM
> 2. change the password in OpenStack so engine will fail to connect and get
> the images list.
> 
> Actual results:
> There is no failure by engine, it keeps trying to refresh the list forever
> 
> Expected results:
> Engine should fail the action after a certain amount of time
> 
> 
> Additional info:
> logs and screenshot

Is there anything in the logs?
Comment 2 Elad 2013-09-15 07:35:11 EDT
> Is there anything in the logs?

2013-09-11 17:00:51,736 INFO  [org.ovirt.engine.core.utils.transaction.TransactionSupport] (ajp-/127.0.0.1:8702-6) transaction rolled back
2013-09-11 17:00:51,737 ERROR [org.ovirt.engine.core.bll.GetImagesListQuery] (ajp-/127.0.0.1:8702-6) Query GetImagesListQuery failed. Exception message is Unauthorized
Comment 3 Ayal Baron 2013-09-16 08:01:28 EDT
(In reply to Elad from comment #2)
> > Is there anything in the logs?
> 
> 2013-09-11 17:00:51,736 INFO 
> [org.ovirt.engine.core.utils.transaction.TransactionSupport]
> (ajp-/127.0.0.1:8702-6) transaction rolled back
> 2013-09-11 17:00:51,737 ERROR [org.ovirt.engine.core.bll.GetImagesListQuery]
> (ajp-/127.0.0.1:8702-6) Query GetImagesListQuery failed. Exception message
> is Unauthorized

Then this is not a bug.
The relevant info is logged, engine has no reason to stop trying (no point in starting to differentiate between the different errors).  Once the problem is resolved then this will go back working.

Note You need to log in before you can comment on or make changes to this bug.