This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1006948 - Setup - When creating read only user, setup doesn't make sure preserved user names are not used.
Setup - When creating read only user, setup doesn't make sure preserved user ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Barak Dagan
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 10:38 EDT by Yaniv Lavi (Dary)
Modified: 2014-01-21 09:59 EST (History)
8 users (show)

See Also:
Fixed In Version: rhevm-dwh-3.3.0-15.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
rhevm-dwh-setup now validates a provided user name before it creates a read-only user. The user provided cannot be one of the reserved users (postgres, engine, engine_history and engine_reports), it cannot be empty and it should not exist in the database.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:59:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19944 None None None Never

  None (edit)
Description Yaniv Lavi (Dary) 2013-09-11 10:38:59 EDT
Description of problem:
When creating read only user, setup doesn't make sure preserved user names are not used. We need to decide, if to fail install on existing user, so roles can be recreated with different password, or disallowing just the preserved user names. 

Version-Release number of selected component (if applicable):
IS14-3.3.0

How reproducible:
Always

Steps to Reproduce:
1. Run setup
2. Enter user 'engine' to be create as read only.

Actual results:
Setup fail on user drop

Expected results:
Should not allow existing user or selecting 'engine', 'engine_reports' and 'engine_history'.

Additional info:
Comment 3 Barak Dagan 2013-11-13 08:28:30 EST
verified on IS22:

rhevm-dwh-3.3.0-20.el6ev.noarch


This utility can configure a read only user for DB access. Would you like to do so? (yes|no): y
Provide a username for read-only user : engine
engine is a reserved username and cannot be used for creating read only user.
Comment 4 Charlie 2013-11-27 19:54:04 EST
This bug is currently attached to errata RHEA-2013:15116. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 09:59:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0036.html

Note You need to log in before you can comment on or make changes to this bug.