This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1006966 - No notification when no host can be chosen as SPM
No notification when no host can be chosen as SPM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.4.0
Assigned To: Tal Nisan
Aharon Canan
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 11:17 EDT by vvyazmin@redhat.com
Modified: 2017-06-20 09:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-31 08:06:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+
amureini: needinfo-


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (4.59 MB, application/x-gzip)
2013-09-11 11:17 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-09-11 11:17:28 EDT
Created attachment 796442 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
No notification when no host can be chosen as SPM

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS13 environment:

RHEVM:  rhevm-3.3.0-0.19.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.13-1.el6ev.noarch
VDSM:  vdsm-4.12.0-105.git0da1561.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create Data Center with multiple Hosts
2. Define all hosts with -1 priority.
3. Check that you are getting notification that no host can be chosen as SPM.

Actual results:
No notification appeared

Expected results:
Appropriate notification appear.

Impact on user:
none

Workaround:
none

Additional info:
Print screen attached

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 3 Allon Mureinik 2013-12-03 07:26:42 EST
Sean,

What's your two cents here?
Should such a conf. even be allowed?
Comment 4 Sean Cohen 2013-12-31 08:06:38 EST
(In reply to Allon Mureinik from comment #3)
No, not a supported configuration (and for that matter, not a bug)
Comment 5 Allon Mureinik 2014-01-01 09:44:52 EST
(In reply to Sean Cohen from comment #4)
> (In reply to Allon Mureinik from comment #3)
> No, not a supported configuration (and for that matter, not a bug)
So shouldn't we have a validation to make sure that at least one host has prioty >-1 ?

Note You need to log in before you can comment on or make changes to this bug.