Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 100700 - gtk2 applications sometimes stop accepting keyboard input
gtk2 applications sometimes stop accepting keyboard input
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-24 10:06 EDT by Wesley Tanaka
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 21:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Tanaka 2003-07-24 10:06:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030723

Description of problem:
Sometimes, gtk2 applications (it mostly happens with those using antialiased
fonts) will get into a mode where they will accept mouse input but will not
accept keyboard input.  It seems to happen sporadically when I'm typing in one
window of the application and a new window appears while I'm typing.

Version-Release number of selected component (if applicable):
gtk2-2.2.1-4 

How reproducible:
Sometimes

Steps to Reproduce:
1. Log in in simplified chinese locale
2. run a program that can create multiple windows (e.g. gaim)
3. type into text fields while new windows are being created.

Actual Results:  All windows will get into a state where they do not accept
keyboard input of any kind.  Mouse input still works.

Expected Results:  should continue to work normally.

Additional info:
Comment 1 Owen Taylor 2003-07-24 14:27:25 EDT
Sadly, I don't think we'll be able to do anything unless you can
provide exact details about a set of steps to reproduce the problem,
at the level of "what keys to press", just running logged in in Chinese 
for a couple of hours isn't really an option for me...
Comment 2 Wesley Tanaka 2003-07-24 15:19:06 EDT
The key to reproducing the bug seems to be typing at the same time that the same
application maps another window.

I just reproduced it now (Firebird 0.6) by:

File:New Window

and then, before the window actually mapped, spamming the keyboard with
keystrokes in this text field.  I'm entering the rest of this comment via cut
and paste, since I can't type in firebird anymore.
Comment 3 Leon Ho 2003-08-01 02:16:32 EDT
I couldn't reproduce it in mozilla or gedit. If it is about gtk+2 it should able to 
reproduce on all of the gtk+2 applications? 
Comment 4 Wesley Tanaka 2003-08-04 12:03:53 EDT
I've seen the bug so far in gaim, mozilla and gedit, as well as with SWT
programs like eclipse, mainly because those applications are the ones that I
often type in.  It may not be a GTK2 bug.  Any ideas how to isolate the part of
software further?
Comment 5 Leon Ho 2003-08-11 21:04:52 EDT
Can you reproduce on any locales (including en_US.UTF-8) Or is there a specific 
locale that you are having problem? 
Comment 6 Wesley Tanaka 2003-08-12 00:09:52 EDT
I am using RH9's simplified chinese locale, which is zh_CN.GB18030 
Comment 7 Leon Ho 2003-08-22 00:34:24 EDT
Try it in other locales like en_US.UTF-8 and see if you got the same problem 
Comment 8 Wesley Tanaka 2003-08-22 05:06:35 EDT
I do not get the same problem in en_US.UTF-8

At first I thought I could reproduce it, but focusing on another window and then
back on the window that had the problem seemed to fix it completely.
Comment 9 Owen Taylor 2003-10-15 14:43:01 EDT
Is this the same as bug 106807?
Comment 10 Wesley Tanaka 2003-10-15 15:15:25 EDT
The problem that I've observed applies only to a single process.  if, for
example, eclipse gets stuck, killing and restarting eclipse fixes the problem. 
If gedit gets stuck, killing and restarting gedit fixes the problem.

If it is the case that bug 106807 is a bug in chinput, that suggests these two
bugs may be different.
Comment 11 Leon Ho 2003-12-07 19:20:30 EST
Sorry I still cannot reproduce it. Can you test on Fedora Core and see
if that still a problem to you?
Comment 12 Wesley Tanaka 2003-12-09 03:35:52 EST
I've partially upgraded my desktop to Fedora, but haven't used it
extensively enough to know if the problem is still there.
Comment 13 Leon Ho 2004-04-06 21:13:53 EDT
I cannot reproduce in FC2 test2. Let me know if this problem still
occur for you in FC2.

Note You need to log in before you can comment on or make changes to this bug.