Bug 1007148 - Should not change the others NICs with bridge when you only confiugred one
Should not change the others NICs with bridge when you only confiugred one
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 22:36 EDT by wanghui
Modified: 2014-01-21 14:49 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
If one NIC was configured as a bridge, the other NICs also appeared to be configured as a bridge. This was caused by a configuration entry being used incorrectly. The configuration entry is now interpreted correctly, so the bridge configuration is only shown for the bridge configured NIC and not for all of them.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:49:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19382 None None None Never

  None (edit)
Description wanghui 2013-09-11 22:36:11 EDT
Description of problem:
It has changed others NICs with bridge when you only configured one.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.auto1817.el6.iso

How reproducible:
100%

Steps to Reproduce:
1. Clean installrhev-hypervisor6-6.5-20130725.0.auto1817.el6.iso.
2. Configure eth0 with dhcp and bridge.
3. Check other NICs.

Actual results:
1. After step3, the other NICs were marked Use Bridge even if them don't choose that.

Expected results:
1. After step3, the other NICs should not be choose with Use Bridge.

Additional info:
Comment 2 Mike Burns 2013-09-12 08:21:18 EDT
I believe it was a global setting so this might not be something easily fixed.  

Fabian can you analyze?
Comment 6 wanghui 2013-10-10 03:32:15 EDT
Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
ovirt-node-3.0.1-3.el6.noarch

Test steps:
1. Clean install rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
2. Configure eth0 with dhcp and bridge.
3. Check other NICs.

Test result:
1. After step3, the configuration of bridge only effect eth0. No other NICs are marked as bridge.

So the bug is fixed in rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso. I will recheck it when I get official build.
Comment 7 wanghui 2013-10-18 06:44:15 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Clean install rhev-hypervisor6-6.5-20131017.0.iso。
2. Configure eth0 with dhcp and bridge.
3. Check other NICs.

Test result:
1. After step3, the configuration of bridge only effect eth0. No other NICs are marked as bridge.

The bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.
Comment 9 Cheryn Tan 2013-11-07 19:31:45 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 errata-xmlrpc 2014-01-21 14:49:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.