Bug 1007213 - ModeShape repository should support upgrade functions
ModeShape repository should support upgrade functions
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: ---
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 02:29 EDT by Horia Chiorean
Modified: 2016-02-10 03:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:57:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2043 Blocker Closed Add capability to run "repository upgrade" operations 2014-02-17 07:48:29 EST

  None (edit)
Description Horia Chiorean 2013-09-12 02:29:30 EDT
We've determined that in certain cases (e.g. changing the predefined node types) we need to provide an upgrade functionality which allows existing clients to be updated to reflect these changes.
Comment 1 JBoss JIRA Server 2013-09-13 09:02:44 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2043

Rebased & merged the first pull request into {master}. Leaving issue open so that some test can be added which validate the functionality.
Comment 2 JBoss JIRA Server 2013-09-13 09:03:14 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2043

Rebased & merged the first pull request into {{master}}. Leaving issue open so that some test can be added which validate the functionality.
Comment 3 JBoss JIRA Server 2013-09-13 09:03:32 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2043

Rebased & merged the first pull request into {{master}}. Leaving issue open so that some tests can be added which validate the functionality.
Comment 4 JBoss JIRA Server 2013-09-16 08:51:03 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2043

Attached a second pull request which contains some tests for the upgrade functions plus a small code refactoring.

Due to the fact that the upgrading mechanism is triggered only on the change of some internal repository state, it's not really possible to cleanly test this behavior out-of-context (at least not without exposing internal data).

Therefore, the functional tests will have to be indirect via the testing of other tasks like MODE-2044.
Comment 5 JBoss JIRA Server 2013-09-16 10:35:09 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2043

Rebased and merged the second pull-request (with tests) into the 'master' branch. Leaving open until it is cherry-picked into the 3.3.x branch.
Comment 11 JBoss JIRA Server 2013-10-24 05:20:57 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2043 to Closed
Comment 12 belong 2013-11-19 18:19:54 EST
Fixed before GA - setting to requires_doc_text- accordingly

Note You need to log in before you can comment on or make changes to this bug.