Bug 100726 - ncpmount: No such device in mount(2)
Summary: ncpmount: No such device in mount(2)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncpfs   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-24 18:31 UTC by ab
Modified: 2007-03-27 04:08 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 21:03:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifconfig output (895 bytes, text/plain)
2003-07-24 18:33 UTC, ab
no flags Details

Description ab 2003-07-24 18:31:08 UTC
Description of problem:

When attempting to mount a remote volume, I receive this error:

"ncpmount: No such device in mount(2)"

Version-Release number of selected component (if applicable):

ncpfs-2.2.1

How reproducible:

always

Steps to Reproduce:
1. "insmod ipx" (to load ipx)
2. "ipx_configure --auto_interface=on --auto_primary=on"
3. "ifconfig" shows IPX/ETHERNET II, "slist" returns server list
4. check local mount point "/baz" exists (yes)
5. "ncpmount -S FOOBAR_FS1 -V /sys/users/baz -U baz -P password /baz"

Actual results:

ncpmount: No such device in mount(2)

Expected results:

mounting of Novell volume at local mount point

Additional info:

kernel 2.4.20-8
see attached for ifconfig output.
I get the same error for mounting "by hand" as above, and also with .nwsclient

When I use the same exact configuration/commands for the same Novell server from
a RH 8 box (kernel 2.4.18-27.8.0, ncpfs-2.2.0.18) the mount succeeds.

Comment 1 ab 2003-07-24 18:33:33 UTC
Created attachment 93114 [details]
ifconfig output

Comment 2 ab 2003-08-07 14:41:10 UTC
I have done some more testing.

Dropped ncpfs back to 2.2.0.18-11, which is what the RH 8 box is using, and get
the same problem.

Upgraded to most current ncpfs release (2.2.3-1, in Raw Hide), still get the
same problem.

At this point I am beginning to wonder if there's a serious RH 9 problem with
ncpfs?  Should I go back to RH 8?

Comment 3 Florian La Roche 2003-08-13 21:03:54 UTC
Other reports suggest that it works ok if the kernel modul is built into
the kernel and not only as loadable kernel modul. Looks like a kernel issue
to me, not something I can fix in this component.
(Overall ncpfs is not fully supported and AFAIK deprecated also in
our Release Notes.)

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.