Bug 1007267 - First login into the Dashboard ends with white screen - wrong redirect
First login into the Dashboard ends with white screen - wrong redirect
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Neus Miras
Jan Hrcek
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-12 04:20 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
white screen (24.39 KB, image/png)
2013-09-12 04:20 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-12 04:20:00 EDT
Created attachment 796679 [details]
white screen

Description of problem:
Similarly to bug 997879, login to Process & Task Dashboard inside the business-central behaves strange. I get a white screen. Server log says:
WARN  [org.jboss.dashboard.ui.components.ControllerStatus] Redirecting to static URI: /redhat/RH-Product-Name.png


Version-Release number of selected component (if applicable):
BPMS 6.0 ER2
Comment 1 Pedro Zapata 2013-09-12 05:20:42 EDT
Login screen should never appear when accessing from Business Central. That's not the expected behaviour.

The reason is SSO is not enabled in the default product configuration configuration.

This has already been reported to the productization team.
Comment 2 Pedro Zapata 2013-09-16 04:36:00 EDT
The problem is that the logo image requires authentication. To reproduce:

1. Open new session.
2. Type http://localhost:8080/dashbuilder/workspace/en/showcase/samples
3. Notice the logo image does not appear. Therefore, authentication is for the image itself.
4. Login
5. The resulting URL is http://localhost:8080/dashbuilder/redhat/RH-Product-Name.png which was not the initial URL. This images displays blank because the image is white with transparent background.
Comment 3 Neus Miras 2013-09-17 05:12:07 EDT
There is a pull request that solves that:

https://github.com/jboss-integration/dashboard-builder/pull/2
Comment 7 Jan Hrcek 2013-10-16 06:01:56 EDT
Ok, verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.