Bug 1007422 - We have to ensure we're using an answer file on additional hosts while setup.
We have to ensure we're using an answer file on additional hosts while setup.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
movciari
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 09:07 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.5.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:53:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19577 None None None Never
oVirt gerrit 19678 None None None Never
oVirt gerrit 19686 None None None Never
Red Hat Product Errata RHBA-2014:0083 normal SHIPPED_LIVE new package: ovirt-hosted-engine-setup 2014-01-21 16:42:22 EST

  None (edit)
Description Leonid Natapov 2013-09-12 09:07:05 EDT
Description of problem:

We have to ensure we're using an answer file on additional hosts while setup.
The answer file is automatically generated on first host, should be copied manually by the user on the additional hosts. We should notify user to copy this file before or during the setup on additional host.
Comment 1 Itamar Heim 2013-09-12 10:03:39 EDT
maybe just ask admin to give the already installed host name, then ask for credentials and scp from it?
Comment 2 Leonid Natapov 2013-09-30 04:58:27 EDT
moving it back to assign.

1. Although the setup asks the user to download answer file  
---
Do you want to scp the answer file from the first host? (Yes, No)[Yes]: yes
Please provide the FQDN or IP of the first host: purple-vds2.qa.lab.tlv.redhat.com
Enter 'root' user password for host purple-vds2.qa.lab.tlv.redhat.com: 
----

it seems that file not being downloaded. Also it would be nice to have some indication if the copy was successful. Something like "answer file successfully copied".
Comment 3 Sandro Bonazzola 2013-09-30 06:55:29 EDT
(In reply to Leonid Natapov from comment #2)
> moving it back to assign.
> 
> 1. Although the setup asks the user to download answer file  
> ---
> Do you want to scp the answer file from the first host? (Yes, No)[Yes]: yes
> Please provide the FQDN or IP of the first host:
> purple-vds2.qa.lab.tlv.redhat.com
> Enter 'root' user password for host purple-vds2.qa.lab.tlv.redhat.com: 
> ----
> 
> it seems that file not being downloaded. Also it would be nice to have some
> indication if the copy was successful. Something like "answer file
> successfully copied".

The file is actually downloaded in Customization Stage as temporary file in $TMPDIR and read by the script. The answer file is then written in /etc/ovirt-hosted-engine-setup after Validation stage.
I'll add the requested note after the download.
Comment 4 Sandro Bonazzola 2013-09-30 09:09:19 EDT
patch merged upstream in master and 1.0 branch.
Comment 6 Charlie 2013-11-27 20:20:21 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 Sandro Bonazzola 2013-12-05 06:03:51 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 8 errata-xmlrpc 2014-01-21 11:53:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.