This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007443 - ovirt-engine-notifier cannot be stopped properly
ovirt-engine-notifier cannot be stopped properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-notification-service (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Martin Perina
Tareq Alayan
infra
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-09-12 09:44 EDT by Martin Perina
Modified: 2016-02-10 14:23 EST (History)
7 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (194.01 KB, application/gzip)
2013-09-12 09:44 EDT, Martin Perina
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19218 None None None Never

  None (edit)
Description Martin Perina 2013-09-12 09:44:50 EDT
Created attachment 796867 [details]
logs

Description of problem:

ovirt-engine-notifier cannot be stopped property using command:

  service ovirt-engine-notifier stop

It takes very long time (around minute) to stop and after it finally stops,
following error appears in /var/log/messages:

ovirt-engine-notifier: ERROR run:485 Error: Had to kill process 16828


Version-Release number of selected component (if applicable):

is13, is14

How reproducible:

100%

Steps to Reproduce:
1. Install RHEVM
2. Run engine-setup successfully
3. Start notifier service using 'service ovirt-engine-notifier start'
4. Stop notifier service using 'service ovirt-engine-notifier stop'

Actual results:

It takes a very long time and service is killed in the end

Expected results:

Stop properly as expected

Additional info:

After installation the notifier should exit on its own, because it's missing required parameter MAIL_SERVER. But the process is stuck and has to be stopped using service command. But even if you add this param and service is running fine, it cannot be stopped properly and it's killed.
Comment 3 Tareq Alayan 2013-09-22 09:33:30 EDT
moving to verified. stopping the service works OK.

Opened a separate bug https://bugzilla.redhat.com/show_bug.cgi?id=1010676 regarding the override conf issue.
Comment 4 Itamar Heim 2014-01-21 17:32:12 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:32:14 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.