Bug 1007465 - SELinux is preventing /usr/sbin/ldconfig from 'add_name' accesses on the directory ld.so.cache~.
SELinux is preventing /usr/sbin/ldconfig from 'add_name' accesses on the dire...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8f873e1122551325390d488e22c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 10:33 EDT by byggztryng
Modified: 2013-09-12 13:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 13:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description byggztryng 2013-09-12 10:33:48 EDT
Description of problem:
Problem occurred after logging in to desktop.
SELinux is preventing /usr/sbin/ldconfig from 'add_name' accesses on the directory ld.so.cache~.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ldconfig should be allowed add_name access on the ld.so.cache~ directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ldconfig_t:s0
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                ld.so.cache~ [ dir ]
Source                        ldconfig
Source Path                   /usr/sbin/ldconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glibc-2.18.90-1.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-77.1.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.0-0.rc0.git16.1.fc21.x86_64
                              #1 SMP Mon Sep 9 14:21:32 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-09-12 10:19:03 EDT
Last Seen                     2013-09-12 10:29:35 EDT
Local ID                      50931079-f98d-42f4-af5f-8d531c627951

Raw Audit Messages
type=AVC msg=audit(1378996175.71:431): avc:  denied  { add_name } for  pid=8645 comm="ldconfig" name="ld.so.cache~" scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1378996175.71:431): arch=x86_64 syscall=open success=no exit=EACCES a0=cc83a0 a1=20241 a2=180 a3=10 items=0 ppid=2656 pid=8645 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=ldconfig exe=/usr/sbin/ldconfig subj=system_u:system_r:ldconfig_t:s0 key=(null)

Hash: ldconfig,ldconfig_t,initrc_tmp_t,dir,add_name

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.12.0-0.rc0.git16.1.fc21.x86_64
type:           libreport

Potential duplicate: bug 981073
Comment 1 Daniel Walsh 2013-09-12 13:47:57 EDT
Looks like some wacky tool created ld.so.cache with the wrong label.

rm -f /etc/ld.so/cache~
restorecon /etc/ld.so.cache

Note You need to log in before you can comment on or make changes to this bug.