Bug 1007468 - man sssd-sudo: improve description of necessary configuration
man sssd-sudo: improve description of necessary configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 10:36 EDT by Dmitri Pal
Modified: 2014-06-18 00:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.11.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2013-09-12 10:36:48 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2085

Change

{{{
When the SSSD is configured to use the IPA provider
}}}

to

{{{
When the SSSD is configured to use the IPA as the ID provider
}}}

since id provider is the one we inherit as sudo provider.

We should also say that sudo has to be put in "services". There is a sample configuration that shows that, but it is not mentioned explicitly.

We should mention that nisdomain has to be configured when using netgroups/hostgroups.
Comment 1 Jakub Hrozek 2013-09-20 14:37:13 EDT
Fixed upstream.
Comment 3 Jakub Hrozek 2013-10-04 09:25:26 EDT
Temporarily moving bugs to MODIFIED to work around errata tool bug
Comment 5 Amith 2013-12-18 07:14:08 EST
Verified the bug on SSSD Version : sssd-1.11.2-10.el7.x86_64

The sssd-sudo man page has been updated with the following information:

1.
Note: in order to use netgroups or IPA hostgroups in sudo rules, you also need to correctly set nisdomainname(1) to your NIS domain name (which equals to IPA domain name when using hostgroups).

2.
CONFIGURING SSSD TO FETCH SUDO RULES
       All configuration that is needed on SSSD side is to extend the list of services with "sudo" in [sssd] section of sssd.conf(5). To speed up the LDAP lookups, you can also set search base for sudo rules using ldap_sudo_search_base option.

       The following example shows how to configure SSSD to download sudo rules from an LDAP server.

           [sssd]
           config_file_version = 2
           services = nss, pam, sudo
           domains = EXAMPLE

           [domain/EXAMPLE]
           id_provider = ldap
           sudo_provider = ldap
           ldap_uri = ldap://example.com
           ldap_sudo_search_base = ou=sudoers,dc=example,dc=com

       When the SSSD is configured to use IPA as the ID provider, the sudo provider is automatically enabled. The sudo search base is configured to use the compat tree (ou=sudoers,$DC).
Comment 6 Ludek Smid 2014-06-13 08:43:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.