Bug 1007496 - Cinder does not support remote TGT
Cinder does not support remote TGT
Status: CLOSED DUPLICATE of bug 890202
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 5.0 (RHEL 7)
Assigned To: Eric Harney
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 11:19 EDT by Yogev Rabl
Modified: 2016-04-26 13:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 09:12:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cinder log files from /var/log/cinder (2.62 KB, application/octet-stream)
2013-09-12 11:20 EDT, Yogev Rabl
no flags Details

  None (edit)
Description Yogev Rabl 2013-09-12 11:19:35 EDT
Created attachment 796914 [details]
packstack installation file

Description of problem:
cannot configure openstack  AIO to work with remote tgt storage.
cinder doesn't trey to connect to the remote server although the iscsi
target directs to the tgt server.

2013-09-12 17:26:35.493 9779 ERROR cinder.brick.local_dev.lvm [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Unable to locate Volume Group cinder-volumes
2013-09-12 17:26:35.494 9779 ERROR cinder.service [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Unhandled exception



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install all the openstack services except cinder with packstack.
2. Install the Cinder manually and configure it according to: http://docs.openstack.org/grizzly/openstack-compute/install/apt/content/cinder-install.html
3. Install and configure a remote TGT server and configure the storage setup according to the same manual.

Actual results:
Error: cinder can't locate the cinder-volumes

Expected results:
an AIO openstack server manages its volumes remotely.

Additional info:
2013-09-12 17:26:34.711 9766 INFO cinder.service [-] Starting 1 workers
2013-09-12 17:26:34.713 9766 INFO cinder.service [-] Started child 9779
2013-09-12 17:26:34.716 9779 AUDIT cinder.service [-] Starting cinder-volume node (version 2013.2)
2013-09-12 17:26:35.086 9779 INFO cinder.openstack.common.rpc.impl_qpid [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Connected to AMQP server on 10.35.104.16:5672
2013-09-12 17:26:35.107 9779 INFO cinder.volume.manager [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Starting volume driver LVMISCSIDriver (2.0.0)
2013-09-12 17:26:35.493 9779 ERROR cinder.brick.local_dev.lvm [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Unable to locate Volume Group cinder-volumes
2013-09-12 17:26:35.494 9779 ERROR cinder.service [req-af7e889e-5989-4f69-90eb-090f96bdd0ea None None] Unhandled exception
2013-09-12 17:26:35.494 9779 TRACE cinder.service Traceback (most recent call last):
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 228, in _start_child
2013-09-12 17:26:35.494 9779 TRACE cinder.service     self._child_process(wrap.server)
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 205, in _child_process
2013-09-12 17:26:35.494 9779 TRACE cinder.service     launcher.run_server(server)
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 96, in run_server
2013-09-12 17:26:35.494 9779 TRACE cinder.service     server.start()
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 385, in start
2013-09-12 17:26:35.494 9779 TRACE cinder.service     self.manager.init_host()
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/volume/manager.py", line 170, in init_host
2013-09-12 17:26:35.494 9779 TRACE cinder.service     self.driver.check_for_setup_error()
2013-09-12 17:26:35.494 9779 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/volume/drivers/lvm.py", line 92, in check_for_setup_error
2013-09-12 17:26:35.494 9779 TRACE cinder.service     raise exception.VolumeBackendAPIException(data=message)
2013-09-12 17:26:35.494 9779 TRACE cinder.service VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Volume Group cinder-volumes does not exist
2013-09-12 17:26:35.494 9779 TRACE cinder.service
2013-09-12 17:26:35.508 9766 INFO cinder.service [-] Child 9779 exited with status 2
2013-09-12 17:26:35.508 9766 INFO cinder.service [-] _wait_child 1
2013-09-12 17:26:35.509 9766 INFO cinder.service [-] wait wrap.failed True
Comment 1 Yogev Rabl 2013-09-12 11:20:28 EDT
Created attachment 796915 [details]
Cinder log files from /var/log/cinder
Comment 3 Eric Harney 2013-09-12 12:56:58 EDT
The error here indicates that there is no cinder-volumes VG on the node running the Cinder volume service.

I'm not sure I understand what you mean by "remote TGT".  The VG and cinder-volume service (which manages tgtd) should be deployed on the same node, is that the case here?
Comment 4 Yogev Rabl 2013-09-15 02:07:39 EDT
Remote TGT means that a TGT storage device can be managed by the Cinder while it is on a different machine. 

The problem is that the Cinder doesn't have a driver to support this scenario, as for an example, a driver for gluster allows the Cinder to create/delete/attach/etc. volumes on a remote storage device. 

Though the cinder.conf configuration file points the iscsi address to the TGT storage device (that is on a different machine) the Cinder searches for the cinder-volumes localy.
Comment 5 Eric Harney 2013-09-16 09:44:06 EDT
(In reply to Yogev Rabl from comment #4)
The iscsi_ip_address option is intended to let you pick the intended IP to use on a multi-homed box, where tgtd is still local and managed by Cinder.  As you note, Cinder doesn't have a driver which supports this scenario.

I think the best thing to fit what you are requesting is the driver work which is planned for Icehouse that will enable use of targetd.  The targetd service manages LVM and LIO to export volumes over iSCSI from a remote box and seems to be what you are after here.
Comment 7 Eric Harney 2013-09-17 14:55:58 EDT
I'd suggest we mark this as a duplicate of bug 890202.
Comment 8 Ayal Baron 2013-10-02 09:12:09 EDT
tgtd is being replaced with lio and targetd is the way to manage lio remotely so Bug 890202 will in effect supply the needed functionality here.

*** This bug has been marked as a duplicate of bug 890202 ***

Note You need to log in before you can comment on or make changes to this bug.