Bug 1007537 - Should behave better when there are pre-existing queues
Should behave better when there are pre-existing queues
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-09-12 13:28 EDT by Tim Waugh
Modified: 2015-02-17 12:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-17 12:10:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2013-09-12 13:28:48 EDT
Description of problem:
If cups-browsed is being used for Browse or BrowsePoll functionality, and the queue it wants to create is already there, it currently just sets the device URI to point to the right place but leaves any PPD as-is.

This is not the best behaviour: it is not a good assumption that the PPD is right for this queue.

Other options:
1. Use a different name so as not to conflict with any existing queue
2. Remove the existing queue first (or at least set its ppd-name to raw)
3. Fail in some way, such as logging an error

Version-Release number of selected component (if applicable):
Comment 1 Tim Waugh 2013-09-17 12:26:11 EDT
Reading through the code, the current behaviour when creating a local queue for remote queue "foobar" is:
* if there is no local queue called "foobar" use "foobar"
* if there is a local queue called "foobar" use "foobar@server.name"
* if that is also taken, give up on that queue

I'm pretty sure this is also how cupsd behaved prior to CUPS 1.6.

Máirín: there was a "foobar@server.name" queue when we were debugging this, but I don't think we ever tried it to see if it worked. My guess is that would have.

So the queue we had been trying might not have been touched by cups-browsed after all, and deleting it just allowed cups-browsed to start using that name (so it worked then).

I'm trying to think about how to change the behaviour to be least-surprise, and I'm just not sure.
Comment 2 Fedora End Of Life 2015-01-09 14:49:24 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2015-02-17 12:10:12 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.