This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1007555 - python-genshi: Broken upgrade path from F18 to F19
python-genshi: Broken upgrade path from F18 to F19
Status: CLOSED DUPLICATE of bug 979866
Product: Fedora
Classification: Fedora
Component: python-genshi (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 14:28 EDT by Kevin Kofler
Modified: 2013-10-02 14:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 14:32:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2013-09-12 14:28:32 EDT
Description of problem:
$ koji latest-pkg f18-updates python-genshi
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
python-genshi-0.7-3.fc18                  f18-updates           lmacken
$ koji latest-pkg f19-updates python-genshi
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
python-genshi-0.7-2.fc19
python-genshi-0.7-3.fc18 > python-genshi-0.7-2.fc19

Version-Release number of selected component (if applicable):
python-genshi-0.7-2.fc19  

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from F18 to F19 with yum distro-sync.

Actual results:
The package is downgraded.

Expected results:
The package is upgraded.

Additional info:
The Fedora 19 and higher builds are missing the following patch:
* Wed May  1 2013 Luke Macken <lmacken@redhat.com> - 0.7-3
- Apply a patch that changes the default encoding back to utf-8
Comment 1 Felix Schwarz 2013-10-02 14:32:54 EDT
It's ok that the patch is not included because F19 ships Trac 1.x (only Trac 0.12 was incompatible with Genshi 0.7, see bug 979866).

Thank you very much for reporting the issue, should be fixed with the latest update in updates-testing. Check bug 979866 for further information.

*** This bug has been marked as a duplicate of bug 979866 ***

Note You need to log in before you can comment on or make changes to this bug.