Bug 1007651 - The system service level agreement preference in GUI is 'Not Set' after reigister and auto-attach in CLI. [NEEDINFO]
The system service level agreement preference in GUI is 'Not Set' after reigi...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 23:52 EDT by qianzhan
Modified: 2013-09-16 01:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 12:41:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
qianzhan: needinfo? (ckozak)


Attachments (Terms of Use)
'service level agreement preference in CLI.png' (127.08 KB, image/png)
2013-09-12 23:54 EDT, qianzhan
no flags Details
'service level agreement preference in GUI.png' (103.64 KB, image/png)
2013-09-12 23:54 EDT, qianzhan
no flags Details
'GUI-auto-attach-SLA-select.png' (1.32 MB, image/png)
2013-09-16 01:32 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-09-12 23:52:57 EDT
Description of problem:
The system service level agreement preference in GUI is 'Not Set' after reigister and auto-attach in CLI.

Version-Release number of selected component (if applicable):
subscription-manager-1.8.22-1.el5
subscription-manager-gui-1.8.22-1.el5
python-rhsm-1.8.17-1.el5

How reproducible:
always

Steps to Reproduce:
1. Register to SAM and auto-attach in CLI:
[root@dhcp-65-86 ~]# subscription-manager register --auto-attach
Username: admin
Password: 
The system has been registered with ID: 8a064848-c982-49af-a5a5-21331221704a 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Desktop
Status:       Subscribed

2. Open GUI and check the system service level agreement preference:
The system service level agreement preference is 'Not Set'. Please see attachment 'service level agreement preference in CLI.png'

3. Repeate step 1 and step 2 in GUI:
The system service level agreement preference is 'Standard'. Please see attachment 'service level agreement preference in GUI.png'

Actual results:
As step 2.

Expected results:
The system service level agreement preference in GUI should display after reigister and auto-attach in CLI.

Additional info:
I tried on stage candlepin, the result is the same as above.
Comment 1 qianzhan 2013-09-12 23:54:09 EDT
Created attachment 797115 [details]
'service level agreement preference in CLI.png'
Comment 2 qianzhan 2013-09-12 23:54:37 EDT
Created attachment 797116 [details]
'service level agreement preference in GUI.png'
Comment 3 Carter Kozak 2013-09-13 12:41:57 EDT
I don't think this is a bug.  You did specify a service level preference when you registered via the GUI, you didn't specify one (via --servicelevel=x) in the command line register.

To avoid setting SLA in the gui, check "manually attach subscriptions" during registration.
Comment 4 qianzhan 2013-09-16 01:30:17 EDT
Firstly, I don't think it is reasonable with the inconsistence between CLI and GUI, because there is always a process of selecting a SLA in GUI no matter with single SLA or multiple SLAs while this not happened in CLI which is incomprehensible. When there is only one available service level for the client, there is a process of selecting service level in GUI but no such process in CLI (as above steps). Also, when there are multiple available service levels for the client, the process of selecting SLA is in GUI but not in CLI:

1. Please see attachment 'GUI-auto-attach-SLA-select.png' for the process of selecting SLA from multiple SLAs in GUI.
2. The following are steps of auto-attach with multiple available service levels in CLI:
(1)
[root@unused-65-238 ~]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

(2)
[root@unused-65-238 ~]# subscription-manager list --consumed | grep 'Service Level'
Service Level:     Standard

(3)
[root@unused-65-238 ~]# subscription-manager service-level
Service level preference not set

Secondly, with step 2.(2) and step 2.(3). The client has consumed subscription with service level 'Standard' but 'subscription-manager service-level' command has not display the current service level supporting the client and I think this is a question.
Comment 5 qianzhan 2013-09-16 01:32:27 EDT
Created attachment 798103 [details]
'GUI-auto-attach-SLA-select.png'

Note You need to log in before you can comment on or make changes to this bug.