Bug 1007667 - fv_* test failed on RHEL5.9 Xen kernel since xenbr0 was not found
fv_* test failed on RHEL5.9 Xen kernel since xenbr0 was not found
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Yu Shao
Red Hat Kernel QE team
:
: 1076336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 01:32 EDT by HP Enterprise Cert team
Modified: 2015-07-13 10:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-13 10:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result File (3.32 MB, application/x-gzip-compressed)
2013-09-13 01:32 EDT, HP Enterprise Cert team
no flags Details

  None (edit)
Description HP Enterprise Cert team 2013-09-13 01:32:37 EDT
Created attachment 797119 [details]
Result File

Description of problem:
Full Virtulization fv_* test failed with RHEL5.9 Xen Kernel since xenbr0 was not found. By default OS installation, there are only 2 network bridges named 'virbr0' and 'xenbr1'. No network bridge device named 'xenbr0'.
Here is the error information during fv_* test.
Submitted tests: hwcert-backend run   --mode auto --test core --server 10.101.2.98
Warning: "virsh start hwcert-x86_64" has output on stderr
error: Failed to start domain hwcert-x86_64
error: POST operation failed: xend_post: error from xen daemon: (xend.err 'Device 0 (vif) could not be connected. Could not find bridge device xenbr0')
fv_core test is running, it takes some time(less than 60 minutes), please be patient ...

Version-Release number of selected component (if applicable):
OS: RHEL5.9 GA <Xen>
Kit: hwcert-client-1.5.9-37.el5

How reproducible:
Always reproduced with default configuration.

Steps to Reproduce:
1. Install RHEL5.9 Xen OS with installation number. 
2. Configure HWCERT kit.
3. Run fv_* test.

Actual results:
fv_* test failed with errors regarding 'xenbr0 not found'.

Expected results:
fv_* test passed.

Additional info:
I upload the result file as attachment.

Workaround:
There is a workaround to fix the issue and fv_* test could be passed. Actually 'virbr0' is good for use, so modify the code to use 'virbr0' as below.
# vi /usr/share/hwcert/lib/hwcert/fvtest.py
guestConfig.write("vif = [ \"mac=00:16:3e:76:b5:99,bridge=virbr0\" ]\n")
Comment 1 Guangze Bai 2014-06-03 08:39:34 EDT
*** Bug 1076336 has been marked as a duplicate of this bug. ***
Comment 6 brose 2015-07-13 10:20:05 EDT
Closing as hwcert-client is obsolete.
Please use redhat-certification-hardware instead.

Note You need to log in before you can comment on or make changes to this bug.