Bug 1007676 - Fail to add phpmyadmin-4 cartridge in INT
Fail to add phpmyadmin-4 cartridge in INT
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 02:05 EDT by Zhe Wang
Modified: 2015-05-14 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:28:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-09-13 02:05:47 EDT
Description of problem:
it always fails to add a phpmyadmin cartridge to an app in INT, on the other hand, there is no such bug in devenv-stage_471.

Version-Release number of selected component (if applicable):
INT(devenv_3779)

How reproducible:
always

Steps to Reproduce:
1. create an app
2. add a mysql cartridge
3. add a phpmyadmin cartridge

Actual results:
The step 3 failed with the errors:
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node)..
Reference ID: ff60a969c46b07602384096c1d9d7392


Expected results:
Adding phpmyadmin cartridge should be successful.

Additional info:
Comment 1 Michal Fojtik 2013-09-13 10:56:48 EDT
Hmm, I'm not able to reproduce this on the latest devenv. Perhaps the INT is missing the phpMyAdmin packages?
Could you please sent me more detailed logs?


 ~ → rhc app create phpmyadmin1 php-5.3
Application Options
-------------------
  Namespace:  mfojtik
  Cartridges: php-5.3
  Gear Size:  default
  Scaling:    no

Creating application 'phpmyadmin1' ... done

 ~ → rhc add-cartridge mysql-5.1 --app phpmyadmin1 
Adding mysql-5.1 to application 'phpmyadmin1' ... done

 ~ → rhc add-cartridge phpmyadmin-4 --app phpmyadmin1 
Adding phpmyadmin-4 to application 'phpmyadmin1' ... done

phpmyadmin-4 (phpMyAdmin 4.0)
-----------------------------
  Gears:          Located with php-5.3, mysql-5.1
  Connection URL: https://phpmyadmin1-mfojtik.dev.rhcloud.com/phpmyadmin/

Use 'rhc env --help' to manage environment variable(s) on this cartridge and application.


Please make note of these MySQL credentials again:
  Root User: adminyxa1LkP
  Root Password: C9fge9GIhSB4
URL: https://phpmyadmin1-mfojtik.dev.rhcloud.com/phpmyadmin/
Comment 2 Zhe Wang 2013-09-16 01:33:59 EDT
Hi, Michal

I was able to reproduce this bug with my Python-2.7 app which was created in INT last Friday. Here is the detail of the app and the failure of adding a phpmyadmin cart

py27 @ http://py27-zwint.int.rhcloud.com/ (uuid: 5236770103ef64253e000094)
  --------------------------------------------------------------------------
    Domain:  zwint
    Created: 11:12 AM
    Gears:   1 (defaults to small)
    Git URL: ssh://5236770103ef64253e000094@py27-zwint.int.rhcloud.com/~/git/py27.git/
    SSH:     5236770103ef64253e000094@py27-zwint.int.rhcloud.com

    python-2.7 (Python 2.7)
    -----------------------
      Gears: Located with mysql-5.1

    mysql-5.1 (MySQL Database 5.1)
    ------------------------------
      Gears:          Located with python-2.7
      Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/
      Database Name:  py27
      Password:       eFkrZVwjEU3Q
      Username:       adminVpd4N1V

When trying to add a phpmyadmin-4 cart to this app, it still failed:

[zhe@fedora runtst]$ rhc cartridge add phpmyadmin-4 -a py27
Adding phpmyadmin-4 to application 'py27' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node)..
Reference ID: ecb644fdb5dda722f30ab68640a16699

Moreover, I was also able to reproduce this bug with a new php-5.3 app in INT.

[zhe@fedora runtst]$ rhc app create phptst php-5.3 mysql-5.1
Application Options
-------------------
  Namespace:  zwint
  Cartridges: php-5.3, mysql-5.1
  Gear Size:  default
  Scaling:    no

Creating application 'phptst' ... done
...

[zhe@fedora runtst]$ rhc cartridge add phpmyadmin-4 -a phptst
Adding phpmyadmin-4 to application 'phptst' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node)..
Reference ID: f7f2ec4011ffe35e557daae06bcb3787

I will reserve these two apps for your further debugging.

Thanks,
Zhe Wang
Comment 3 Zhe Wang 2013-09-16 01:42:12 EDT
phpMyAdmin-4 is in the cartridge list of INT:

phpmyadmin-4        phpMyAdmin 4.0                              addon

However, I am not able to get the logs in development.log in INT since I dont have the root permission. Hope the reference IDs in comment#2 may help.
Comment 4 Zhe Wang 2013-09-16 02:21:28 EDT
Lowered down the severity of this bug since it is not reproducible in STG.
Comment 5 Michal Fojtik 2013-09-16 03:34:47 EDT
I think this bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=1007730 but I will do more testing today.
Comment 9 Zhe Wang 2013-09-22 05:38:54 EDT
Verified this bug in the latest INT.
Comment 10 Jhon Honce 2014-06-09 11:37:34 EDT
Clearing needinfo flag

Note You need to log in before you can comment on or make changes to this bug.