Bug 100773 - default Greek Keyboard settings
default Greek Keyboard settings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-25 03:33 EDT by Nikos Charonitakis
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 20:53:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2003-07-25 03:33:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
starting from 9 version and now with beta1 Greek users have some confusion with
Greek keyboard.
Speaking for beta:if a user selects Greek keyboard during installation then cant
create passwords because when trying to enter Greek characters in pass boxes
system complaining about not accepted non ascii characters.
By pressing Lshift + Rshift keyboard returns to en mode so he or she can
continue.
The same problem comes again when instalation is finished and user tries
to login but keyboard insists writing in Greek.
Not everyone knows that Lshift+Rshift can change the keymap to en
so we have many disappointed Greek users keep trying to login in their
fresh RH installation...
So i suggest when a user selects Greek keyboard default keymap must be
en.
I think that the same issue appears on RH9 to.

It easy fix i think.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install redhat linux9
2.or install severn
3.
    

Additional info:
Comment 1 Jeremy Katz 2003-10-16 13:56:19 EDT
So you're saying that X keymap should default to using normal ascii and require
switching to get into the greek mode?
Comment 2 Nikos Charonitakis 2003-10-16 14:56:16 EDT
yes

Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us,el"
	Option	    "XkbOptions" "grp:shift_toggle,grp_led:scroll"

This have to be the default setting in ΧF86Config.

Also the same configuration needed in anaconda
(when a user chooses Greek keyboard)
Comment 3 Jeremy Katz 2003-10-16 15:06:18 EDT
Okay, fixed to be like this with rhpl-0.119
Comment 4 Nikos Charonitakis 2003-11-07 20:53:46 EST
fixed in fedora Core 1
thank you.

Note You need to log in before you can comment on or make changes to this bug.