Bug 1007748 - Installer: Add new line after options during console installation
Installer: Add new line after options during console installation
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER3
: EAP 6.2.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 05:12 EDT by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-09-13 05:12:44 EDT
This is more just a usability issue than a bug. 

In previous version of -console installer there was always a new line after "press 1 to continue, 2 to quit, 3 to redisplay.". So the user input looks like:
 
press 1 to continue, 2 to quit, 3 to redisplay.
1

But in 6.2 there is no new line after this string so the user input is appended to this message like:

press 1 to continue, 2 to quit, 3 to redisplay.1

There is always a new line before user input for all other options.
Comment 1 Miles Tjandrawidjaja 2013-09-13 14:24:49 EDT
Newline has been added whenever prompting the user for input during a console installation.

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=ceb1dade127e3d6db977648125fd2fac6d72384f
Comment 2 Petr Kremensky 2013-09-18 02:29:26 EDT
This is still same in ER2 as it was in ER1.
Comment 3 Petr Kremensky 2013-09-26 08:01:14 EDT
Please move all BZs ready for verification to ON_QA once the target milestone was released, thanks. 

Verified on EAP 6.2.0.ER3

Note You need to log in before you can comment on or make changes to this bug.