Bug 1007777 - Moving fields in a form doesn't work
Moving fields in a form doesn't work
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Pere Fernàndez
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 05:54 EDT by Michael
Modified: 2013-10-21 11:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 11:07:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2013-09-13 05:54:26 EDT
Description of problem:
When defining a form and we want to move /slide a field with the symbol of the "arrows showing in all directions" it is not possible to move the fields. They pop back from where we started.

Version-Release number of selected component (if applicable):
kie-wb-6.0.0-SNAPSHOT-as-7.war in JBoss 6.1

How reproducible:


Steps to Reproduce:
1. create a form
2. try to move a field using the arrow symbol
3.
Comment 2 Pere Fernàndez 2013-09-13 11:11:13 EDT
I tried to move fields and is working fine. Maybe you are trying to do it via drag & drop? Form editor isn't drag & drop, you should first click on the "move" icon and all the areas where the field can be dropped will appear on the form, after that you must click on the area where you want to leave the field.
Comment 4 Michael 2013-10-17 04:24:27 EDT
It is working fine.
I tried it to move with "drag and drop" and this is not working.
If you click on a form field and activate it, you can move it then.
Comment 5 Tomas Livora 2013-10-21 11:07:55 EDT
It is not a bug because the editor does not support drag&drop. As mentioned above a field can be moved by clicking on the 'move' icon and then choosing the area where it will be placed.

Note You need to log in before you can comment on or make changes to this bug.