Bug 1007779 - Failed to execute drush commands for existing drupal-quickstart app after migration
Failed to execute drush commands for existing drupal-quickstart app after mig...
Status: CLOSED DUPLICATE of bug 1008043
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 05:54 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 12:38:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-09-13 05:54:57 EDT
Description of problem:
The drush commands will failed to execute any more for existing drupal-quickstart app after migration.

Version-Release number of selected component (if applicable):
devenv-stage_465 to devenv-stage_471

How reproducible:
always

Steps to Reproduce:
1. Launch devenv-stage_465 ami
2. Create a drupal quickstart app
rhc app create cdrupal php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
3. yum clean all && yum update -y
4. Clear broker cache
5. Restart service 
rhc-broker
mcollective 
rhc-datastore
activemq
6. Clear pending ops
7. Migrate datastore
# rhc admin-migrate-datastore --version 2.0.33 --non-compatible
8. Migrate gears
# oo-admin-upgrade upgrade-node --version 2.0.33 --ignore-cartridge-version
9. Clear broker cache
10. SSH into this app and come into the project home dir
cd app-root/runtime/repo/php
11. Execute drush command like below
drush core-status                                             

Actual results:
<h1>Additional uncaught exception thrown while handling exception.</h1><h2>Original</h2><p>PDOException: SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown table engine &amp;#039;InnoDB&amp;#039;: SELECT 1 FROM {blocked_ips} WHERE ip = :ip; Array
(
    [:ip] =&amp;gt; 127.0.0.1
)
 in drupal_is_denied() (line 1915 of /var/lib/openshift/183ba8e41c5511e39d9a22000ab311c7/app-root/data/downloads/drupal-7.23/includes/bootstrap.inc).</p><h2>Additional</h2><p>PDOException: SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown table engine &amp;#039;InnoDB&amp;#039;: SELECT * FROM {system} WHERE type = &amp;#039;theme&amp;#039; OR (type = &amp;#039;module&amp;#039; AND status = 1) ORDER BY weight ASC, name ASC; Array
(
)
 in system_list() (line 165 of /var/lib/openshift/183ba8e41c5511e39d9a22000ab311c7/app-root/data/downloads/drupal-7.23/includes/module.inc).</p><hr />Drush command terminated abnormally due to an unrecoverable error.  
  
Expected results:
The drush commands for existing drupal-quickstart app after migration should be executed successfully.

Additional info:
Comment 1 Vojtech Vitek 2013-09-13 08:04:54 EDT
@chunchen, can you please retest against the following?
> 11. Execute drush command like below
$OPENSHIFT_PHP_DIR/phplib/pear/pear/drush core-status

I'd say that this is rather expected behavior, as described in https://github.com/openshift/drupal-quickstart/pull/5#issuecomment-22876043 for the old drupal-quickstart users.

I will double check this..
Comment 2 chunchen 2013-09-15 23:24:24 EDT
@Vojtech Vitek, checked this issue with command in Comment 1, it is still reproduced on devenv-stage_465 to devenv-stage_472. Thanks!
Comment 3 Vojtech Vitek 2013-09-16 12:38:31 EDT
According to
> PDOException: SQLSTATE[42000]: Syntax error or access
> violation: 1286 Unknown table engine &amp;#039;InnoDB&amp;#039;
message, this bug is duplicate of bug 1008043.

*** This bug has been marked as a duplicate of bug 1008043 ***

Note You need to log in before you can comment on or make changes to this bug.