Bug 1007994 - neutron requires pyparsing 1.5.7 but we only provide it up to 1.5.6
neutron requires pyparsing 1.5.7 but we only provide it up to 1.5.6
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-quantumclient (Show other bugs)
Unspecified Unspecified
unspecified Severity urgent
: async
: 3.0
Assigned To: Terry Wilson
Ofer Blaut
: ZStream
Depends On:
  Show dependency treegraph
Reported: 2013-09-13 13:31 EDT by Giulio Fidente
Modified: 2016-04-26 11:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-11-04 23:03:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Giulio Fidente 2013-09-13 13:31:16 EDT
Description of problem:
packstack installation fails with the followin

  ERROR : Error during puppet run : err: Could not prefetch quantum_network provider 'quantum': Execution of '/usr/bin/quantum net-list --format=csv --column=id --quote=none' returned 1: (pyparsing 1.5.6 (/usr/lib/python2.6/site-packages), Requirement.parse('pyparsing==1.5.7'))

apparently neutron requires pyparsing 1.5.7, we only provide it in version 1.5.6

Version-Release number of selected component (if applicable):

How reproducible:
try to install using packstack
Comment 1 Lon Hohberger 2013-10-23 19:41:09 EDT
Terry / Padraig - is this a bogus requirement, or is there some functional difference that we need to deal with here?

I tried to reproduce this on 2013.1.3 and 2013.1.4 builds, and did not have any issue:

[root@localhost ~(keystone_admin)]# /usr/bin/quantum net-list --format=csv 
[root@localhost ~(keystone_admin)]# rpm -q pyparsing openstack-quantum
Comment 2 Pádraig Brady 2013-11-04 11:43:00 EST
So 1.5.6 -> 1.5.7 was made in grizzly indirectly due to python 3 adjustments
which leads to...
That commit again only references python 3 stuff,
and not whether python-cmd2 actually does need >= 1.5.7
I suspect that was the latest 1.5.x release at the time
of the commit which I've seen people reference for some unknown reason

So 2 issues.

1. 1.5.7 is probably a false requirement. 1.5.6 is fine.
2. There should be no runtime dep management in released packages.
I thought the quantumclient package might be referencing it,
but version 2.2.1 seems to avoid the runtime check, which seems to
be for version 1.5.6 in any case.

Could you please search for which egg has pyparsing==1.5.7 present.

Comment 3 Terry Wilson 2013-11-04 19:25:13 EST
I just went through a packstack --allinone with the 2013-11-01.1 puddle and did not get this error. This appears to be a false requirement *and* to no longer be an issue.

Giulio Fidente: Can you verify that this issue no longer occurs so we can close the issue?
Comment 4 Giulio Fidente 2013-11-04 20:22:58 EST
Confirmed, not an issue with 2013-11-01.1 anymore.

I also don't seem to find any reference to pyparsing 1.5.7 in pip-requires from stable/grizzly at all in github https://github.com/openstack/requirements/blob/stable/grizzly/tools/pip-requires

For future reference, the actual quantum/neutron client packaged with the build 2013-09-06.2 is python-quantumclient-2.2.1-2.el6ost.noarch.rpm
Comment 5 Terry Wilson 2013-11-04 23:03:22 EST
Closing as it seems to have, at the very least, been fixed already.

Note You need to log in before you can comment on or make changes to this bug.