Bug 1008039 - Unable to discover iSCSI targets when portal exports something on IPv6
Unable to discover iSCSI targets when portal exports something on IPv6
Status: CLOSED DUPLICATE of bug 972450
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: nobody nobody
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 18:21 EDT by Libor Zoubek
Modified: 2016-02-10 13:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 04:02:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-09-13 18:21:42 EDT
Description of problem: vdsm is not able to parse response from iscsadm discovery when target portal exports at least one target on IPv6


Version-Release number of selected component (if applicable):
RHEVH 6.4 (20130815.0.el6_4)

How reproducible: always


Steps to Reproduce:
1. setup tgtd on some target host to export something on IPv6
2. select Host in UI and try to discover on your target

This is what returns

iscsiadm -m discoverydb -t sendtargets -I default -p 192.168.130.101:3260 --discover

192.168.130.101:3260,1 iqn.1992-01.com.lsi:2365.60080e50002d65400000000051ac6bde
[fe80:0000:0000:0000:0280:e5ff:fe26:f773]:3260,1 iqn.1992-01.com.lsi:2365.60080e50002d65400000000051ac6bde
192.168.131.101:3260,1 iqn.1992-01.com.lsi:2365.60080e50002d65400000000051ac6bde
192.168.132.101:3260,1 iqn.1992-01.com.lsi:2365.60080e50002d65400000000051ac6bde
192.168.133.101:3260,1 iqn.1992-01.com.lsi:2365.60080e50002d65400000000051ac6bd


Actual results:
RHEV-M UI claims no targets have been discovered, this appears in vdsm.log

Thread-11201::ERROR::2013-09-13 22:18:06,059::task::850::TaskManager.Task::(_setError) Task=`57269ae6-ed0c-45ed-a518-f063a757a4db`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
  File "/usr/share/vdsm/logUtils.py", line 41, in wrapper
  File "/usr/share/vdsm/storage/hsm.py", line 2887, in discoverSendTargets
  File "/usr/share/vdsm/storage/iscsi.py", line 214, in discoverSendTargets
  File "/usr/share/vdsm/storage/iscsiadm.py", line 202, in discoverydb_discover
ValueError: too many values to unpack


Expected results: targets are correctly detected


Additional info:
Comment 1 Ayal Baron 2013-09-23 04:02:08 EDT

*** This bug has been marked as a duplicate of bug 972450 ***

Note You need to log in before you can comment on or make changes to this bug.