Bug 1008044 - Cloning repository should show rhc git-clone
Cloning repository should show rhc git-clone
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Documentation (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bmoss
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 19:58 EDT by Naveen Malik
Modified: 2015-07-19 20:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.12 Build Name: 18397, User Guide-null-1.0 Build Date: 29-08-2013 13:11:27 Topic ID: 18303-491199 [Latest]
Last Closed: 2013-09-25 20:51:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveen Malik 2013-09-13 19:58:54 EDT
Title: Cloning the Application Git Repository

Describe the issue:
Steps to clone are more complicated that necessary since this is simplified by rhc.

Suggestions for improvement:
Show use of rhc git-clone <app>

Additional information:
Usage: rhc git-clone <app> [--namespace NAME]

This is a convenience wrapper for 'git clone' with the added benefit of adding configuration data such as the application's UUID to the local repository.
It also automatically figures out the Git url from the application name so you don't have to look it up.


Options
  -n, --namespace NAME      Namespace of the application
  -r, --repo dir            Path to the Git repository (defaults to ./$app_name)
  -a, --app name            The application you wish to clone

Global Options
  -l, --rhlogin LOGIN       OpenShift login
  -p, --password PASSWORD   OpenShift password
  --token TOKEN             An authorization token for accessing your account.
  --server NAME             An OpenShift server hostname (default: openshift.redhat.com)
  --timeout SECONDS         The timeout for operations

  See 'rhc help options' for a full list of global options.

Note You need to log in before you can comment on or make changes to this bug.