Bug 1008061 - everyday yum update problems
everyday yum update problems
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 04:18 EDT by Michael
Modified: 2013-09-16 08:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 08:02:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2013-09-14 04:18:47 EDT
Description of problem:
Many! Mirrors (everyday) not available

Version-Release number of selected component (if applicable):
FC19

How reproducible:
start yum, 'clean all' (cache) and then yum update

Steps to Reproduce:
1. yum clean all
2. yum update
3. mirrors are not available

Actual results & Additional info:

Anderer Spiegelserver wird versucht.
(22/40): dhclient-4.2.5-15.fc19_4.2.5-20.fc19.x86_64.drpm                                    |  95 kB  00:00:00     
(23/40): libreoffice-emailmerge-4.1.1.2-4.fc19.x86_64.rpm                                    |  59 kB  00:00:00     
selinux-policy-devel-3.12.1-74 FAILED                                          
http://fedora.mirrors.ovh.net/linux/updates/19/x86_64/drpms/selinux-policy-devel-3.12.1-74.2.fc19_3.12.1-74.3.fc19.noarch.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
satyr-0.7-1.fc19_0.9-1.fc19.x8 FAILED                                             ] 629 kB/s | 3.2 MB  00:00:32 ETA 
http://ftp.pbone.net/pub/fedora/linux/updates/testing/19/x86_64/drpms/satyr-0.7-1.fc19_0.9-1.fc19.x86_64.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreport-anaconda-2.1.7-1.fc1 FAILED                                          
http://mirror.arlug.ro/pub/fedora/linux/updates/testing/19/x86_64/libreport-anaconda-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(24/40): openvpn-2.3.2-1.fc19_2.3.2-4.fc19.x86_64.drpm                                       | 301 kB  00:00:00     
(25/40): libreport-plugin-bugzilla-2.1.7-1.fc19.x86_64.rpm                                   |  67 kB  00:00:00     
libreport-plugin-reportuploade FAILED                                          
http://mirror.arlug.ro/pub/fedora/linux/updates/testing/19/x86_64/libreport-plugin-reportuploader-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
control-center-filesystem-3.8. FAILED                                             ] 682 kB/s | 3.7 MB  00:00:29 ETA 
http://fedora.mirrors.ovh.net/linux/updates/testing/19/x86_64/control-center-filesystem-3.8.5-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
wireshark-gnome-1.10.2-5.fc19. FAILED                                          
http://mirror.arlug.ro/pub/fedora/linux/updates/testing/19/x86_64/wireshark-gnome-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
wireshark-1.10.2-5.fc19.x86_64 FAILED                                          
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/wireshark-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreport-web-2.1.7-1.fc19.x86 FAILED                                          
http://ftp.byfly.by/pub/fedoraproject.org/linux/updates/testing/19/x86_64/libreport-web-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreoffice-calc-4.1.1.2-3.fc1 FAILED                                             ] 729 kB/s | 4.1 MB  00:00:26 ETA 
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/19/x86_64/drpms/libreoffice-calc-4.1.1.2-3.fc19_4.1.1.2-4.fc19.x86_64.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(26/40): libreoffice-impress-4.1.1.2-3.fc19_4.1.1.2-4.fc19.x86_64.drpm                       |  56 kB  00:00:00     
libreport-2.1.6-2.fc19_2.1.7-1 FAILED                                          
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/drpms/libreport-2.1.6-2.fc19_2.1.7-1.fc19.x86_64.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(27/40): libreport-python-2.1.6-2.fc19_2.1.7-1.fc19.x86_64.drpm                              |  41 kB  00:00:00     
selinux-policy-devel-3.12.1-74 FAILED                                             ] 858 kB/s | 5.5 MB  00:00:21 ETA 
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/19/x86_64/drpms/selinux-policy-devel-3.12.1-74.2.fc19_3.12.1-74.3.fc19.noarch.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
satyr-0.7-1.fc19_0.9-1.fc19.x8 FAILED                                          
http://fedora.mirrors.ovh.net/linux/updates/testing/19/x86_64/drpms/satyr-0.7-1.fc19_0.9-1.fc19.x86_64.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreport-anaconda-2.1.7-1.fc1 FAILED                                             ] 895 kB/s | 5.9 MB  00:00:19 ETA 
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/libreport-anaconda-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreport-plugin-reportuploade FAILED                                          
http://fedora.mirrors.ovh.net/linux/updates/testing/19/x86_64/libreport-plugin-reportuploader-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
control-center-filesystem-3.8. FAILED                                             ] 930 kB/s | 6.3 MB  00:00:18 ETA 
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/control-center-filesystem-3.8.5-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
wireshark-gnome-1.10.2-5.fc19. FAILED                                             ] 963 kB/s | 6.8 MB  00:00:17 ETA 
http://fedora.mirrors.ovh.net/linux/updates/testing/19/x86_64/wireshark-gnome-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
wireshark-1.10.2-5.fc19.x86_64 FAILED                                             ] 994 kB/s | 7.2 MB  00:00:16 ETA 
http://mirror.arlug.ro/pub/fedora/linux/updates/testing/19/x86_64/wireshark-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
libreport-web-2.1.7-1.fc19.x86 FAILED                                          
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/libreport-web-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(28/40): selinux-policy-targeted-3.12.1-74.3.fc19.noarch.rpm                                 | 4.0 MB  00:00:03     
(29/40): libreoffice-calc-4.1.1.2-3.fc19_4.1.1.2-4.fc19.x86_64.drpm                          |  65 kB  00:00:00     
satyr-0.7-1.fc19_0.9-1.fc19.x8 FAILED                                             ] 918 kB/s | 7.6 MB  00:00:17 ETA 
http://ftp.halifax.rwth-aachen.de/fedora/linux/updates/testing/19/x86_64/drpms/satyr-0.7-1.fc19_0.9-1.fc19.x86_64.drpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(30/40): libreport-2.1.6-2.fc19_2.1.7-1.fc19.x86_64.drpm                                     | 139 kB  00:00:00     
(31/40): libreport-plugin-reportuploader-2.1.7-1.fc19.x86_64.rpm                             |  42 kB  00:00:00     
(32/40): selinux-policy-devel-3.12.1-74.2.fc19_3.12.1-74.3.fc19.noarch.drpm                  | 1.8 MB  00:00:01     
(33/40): control-center-filesystem-3.8.5-1.fc19.x86_64.rpm                                   |  15 kB  00:00:00     
(34/40): abrt-libs-2.1.7-1.fc19.x86_64.rpm                                                   |  92 kB  00:00:04     
libreport-web-2.1.7-1.fc19.x86 FAILED                                          
http://mirror.arlug.ro/pub/fedora/linux/updates/testing/19/x86_64/libreport-web-2.1.7-1.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(35/40): libreport-anaconda-2.1.7-1.fc19.x86_64.rpm                                          |  36 kB  00:00:00     
wireshark-gnome-1.10.2-5.fc19. FAILED                                          
http://mirror.i3d.net/pub/fedora/linux/updates/testing/19/x86_64/wireshark-gnome-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
wireshark-gnome-1.10.2-5.fc19. FAILED                                             ] 1.1 MB/s | 9.9 MB  00:00:12 ETA 
http://ftp.byfly.by/pub/fedoraproject.org/linux/updates/testing/19/x86_64/wireshark-gnome-1.10.2-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
(36/40): libreport-web-2.1.7-1.fc19.x86_64.rpm                                               |  39 kB  00:00:00     
(37/40): satyr-0.7-1.fc19_0.9-1.fc19.x86_64.drpm                                             | 116 kB  00:00:00     
(38/40): libreoffice-pyuno-4.1.1.2-3.fc19_4.1.1.2-4.fc19.x86_64.drpm                         | 124 kB  00:00:05     
(39/40): wireshark-gnome-1.10.2-5.fc19.x86_64.rpm                                            | 970 kB  00:00:04     
(40/40): wireshark-1.10.2-5.fc19.x86_64.rpm                                                  |  12 MB  00:00:10     
/usr/share/locale/zh_TW/LC_MESSAGES/abrt.mo: No such file or directory
cannot reconstruct rpm from disk files
Finishing delta rebuilds of 13 package(s) (99 M)


yes, everyday and ANY yum update (via bash) looks like this.

accessibility of other server / services is tested and works
Comment 1 Zdeněk Pavlas 2013-09-16 08:02:43 EDT
Hi, thanks for the report.  I can only confirm the problem.. Few of the files that have failed ARE now present on the respective mirrors, but most are still "404 Not found".  This is a problem with mirror setup and network infrastructure, and there is no way to fix this on the client side.

From my POV, the important thing to know is if the failover to a different mirror worked, and whether RPM was downloaded instead when delta file download/rebuild had failed.

Note You need to log in before you can comment on or make changes to this bug.