Bug 1008112 - Bluetooth DUN + suspend breaks the kernel
Bluetooth DUN + suspend breaks the kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 17:28 EDT by Björn Persson
Modified: 2014-01-03 23:26 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 23:26:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from a rare case when there was something in the log (91.19 KB, text/plain)
2013-09-14 17:28 EDT, Björn Persson
no flags Details

  None (edit)
Description Björn Persson 2013-09-14 17:28:23 EDT
Created attachment 797713 [details]
log from a rare case when there was something in the log

Description of problem:
I've got a laptop, a Clevo W25CEW, running Fedora 19. It tends to become very unstable when I use Bluetooth, especially Bluetooth Dial-Up Networking.

I've tried both the built-in Bluetooth radio and a USB Bluetooth dongle, and had similar problems with both. If I connect to the Internet by Bluetooth DUN and later suspend the computer, then the system almost always breaks in some way when I resume it or shortly thereafter. How it breaks varies. It can be a complete freeze of the GUI, a spontaneous reboot or a kernel panic. Sometimes the system freezes even before I try to suspend it, sometimes already when I close the DUN connection, and sometimes things start acting weird even if I don't use DUN but use other Bluetooth functions, but the combination of DUN and suspend pretty much guarantees some kind of crash or freeze.

It seems likely that something Bluetooth-related corrupts the kernel memory when the DUN connection is closed.

Usually I don't find anything special in the log from the time of the crash, but in one case a series of oopses were logged. In this case the screen went black a few seconds after resume and wouldn't light up again, so I had to turn the computer off with the power button. I'm attaching the log from resume to power off.


Version-Release number of selected component (if applicable):
The problem has been going on across several kernel upgrades. Currently I have kernel-3.10.11-200.fc19.x86_64 installed. The log is from kernel-3.10.10-200.fc19.x86_64.


How reproducible:
It almost always breaks, but the way it breaks varies.


Steps to Reproduce:
1. Use Bluetooth DUN.
2. Suspend (if the system still works).
3. Resume.

  
Actual results:
Kernel panic, or a freeze, or a spontaneous reboot, or a series of oopses and a black screen.


Expected results:
No breakage.


Additional info:
I want to help in any way I can to get this problem fixed, but I'm not familiar with kernel debugging. Please let me know how I can help with diagnosing the problem.
Comment 1 Josh Boyer 2013-09-18 16:44:10 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 2 Björn Persson 2013-09-24 20:07:24 EDT
Still present in Linux 3.11.1.
Comment 3 Stan King 2013-10-13 20:18:01 EDT
I'm seeing something similar, except that I don't need to suspend and resume to get the panic.  All I need to do is drop the Bluetooth network connection, and the machine will eventually panic within the next few minutes.  On the bright side of things, it sometimes writes data to the log before dying.  Does anyone know if that's already reported, or shall I file a new bug?
Comment 4 Björn Persson 2013-10-14 10:35:17 EDT
As I already mentioned, my computer sometimes crashes already when I close the connection or shortly thereafter. It's quite possible that it would have crashed eventually every time if I hadn't been so quick to suspend it.
Comment 5 Samuel Sieb 2013-10-22 18:43:21 EDT
At least for me this happens only when I suspend while the bluetooth DUN is connected.  If I disconnect before suspending then there is no problem.  That's the workaround I will be using from now on.  Something gets jammed in the kernel the next time you try to connect.  At some point the whole system might hang and I've never been able to successfully reboot after it.

I have some logs from when it happens.  The first connection attempt after resume gets this:
Oct 22 13:23:15 worklap NetworkManager[492]: <warn> Error connecting with bluez: Timeout was reached
Oct 22 13:23:15 worklap NetworkManager[492]: <info> (40:B0:EA:0B:20:4B): device state change: config -> failed (reason 'bluetooth-failed') [50 120 44]
Oct 22 13:23:15 worklap NetworkManager[492]: <warn> Activation (40:B0:EA:0B:20:4B) failed for connection 'My Network'

Trying again gets this:
Oct 22 13:23:25 worklap kernel: WARNING: CPU: 2 PID: 300 at fs/sysfs/dir.c:530 sysfs_add_one+0xa5/0xd0()
Oct 22 13:23:25 worklap kernel: sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/bluetooth/hci0/hci0:12'
Oct 22 13:23:25 worklap kernel: Modules linked in: tun fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack rfcom
Oct 22 13:23:25 worklap kernel:  sdhci mmc_core bluetooth tpm_tis tpm_infineon rfkill lpc_ich mfd_core mperf hp_accel lis3lv02d input_polldev snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore tpm tpm_bios shpchp e1000e mei_me mei ptp pps_core wmi uinput i915 firewire_ohci i2c_algo_bit drm_kms_helper firewire_core drm crc_itu_t i2c_core video
Oct 22 13:23:25 worklap kernel: CPU: 2 PID: 300 Comm: kworker/u17:0 Not tainted 3.11.4-201.fc19.x86_64 #1
Oct 22 13:23:25 worklap kernel: Hardware name: Hewlett-Packard HP EliteBook 2760p/162A, BIOS 68SOU Ver. F.22 01/05/2012
Oct 22 13:23:25 worklap kernel: Workqueue: hci0 hci_rx_work [bluetooth]
Oct 22 13:23:25 worklap kernel:  0000000000000009 ffff88022a711a60 ffffffff8164783f ffff88022a711aa8
Oct 22 13:23:25 worklap kernel:  ffff88022a711a98 ffffffff8106715d 00000000ffffffef ffff8801fa852af0
Oct 22 13:23:25 worklap kernel:  ffff88022a711b40 ffff8802066d2000 0000000000000000 ffff88022a711af8
Oct 22 13:23:25 worklap kernel: Call Trace:
Oct 22 13:23:25 worklap kernel:  [<ffffffff8164783f>] dump_stack+0x45/0x56
Oct 22 13:23:25 worklap kernel:  [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
Oct 22 13:23:25 worklap kernel:  [<ffffffff810671cc>] warn_slowpath_fmt+0x4c/0x50
Oct 22 13:23:25 worklap kernel:  [<ffffffff8121b8a5>] sysfs_add_one+0xa5/0xd0
Oct 22 13:23:25 worklap kernel:  [<ffffffff8121ba71>] create_dir+0x71/0xd0
Oct 22 13:23:25 worklap kernel:  [<ffffffff8121be12>] sysfs_create_dir+0x92/0xf0
Oct 22 13:23:25 worklap kernel:  [<ffffffff812fcc46>] kobject_add_internal+0xb6/0x2f0
Oct 22 13:23:25 worklap kernel:  [<ffffffff812fd115>] kobject_add+0x65/0xb0
Oct 22 13:23:25 worklap kernel:  [<ffffffff8118da0e>] ? kfree+0x13e/0x180
Oct 22 13:23:25 worklap kernel:  [<ffffffff813eebc5>] device_add+0x125/0x7a0
Oct 22 13:23:25 worklap kernel:  [<ffffffff813ed327>] ? dev_set_name+0x47/0x50
Oct 22 13:23:25 worklap kernel:  [<ffffffffa03a357e>] hci_conn_add_sysfs+0x4e/0xd0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffffa03970dc>] hci_event_packet+0x186c/0x2ea0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffff8109ef67>] ? dequeue_entity+0x107/0x520
Oct 22 13:23:25 worklap kernel:  [<ffffffff8109f8ce>] ? dequeue_task_fair+0x41e/0x620
Oct 22 13:23:25 worklap kernel:  [<ffffffffa0387cb8>] hci_rx_work+0x1b8/0x3c0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffff810810d5>] process_one_work+0x175/0x430
Oct 22 13:23:25 worklap kernel:  [<ffffffff81081cfb>] worker_thread+0x11b/0x3a0
Oct 22 13:23:25 worklap kernel:  [<ffffffff81081be0>] ? rescuer_thread+0x340/0x340
Oct 22 13:23:25 worklap kernel:  [<ffffffff81088640>] kthread+0xc0/0xd0
Oct 22 13:23:25 worklap kernel:  [<ffffffff81088580>] ? insert_kthread_work+0x40/0x40
Oct 22 13:23:25 worklap kernel:  [<ffffffff8165696c>] ret_from_fork+0x7c/0xb0
Oct 22 13:23:25 worklap kernel:  [<ffffffff81088580>] ? insert_kthread_work+0x40/0x40

and

Oct 22 13:23:25 worklap kernel: WARNING: CPU: 2 PID: 300 at lib/kobject.c:196 kobject_add_internal+0x1e4/0x2f0()
Oct 22 13:23:25 worklap kernel: kobject_add_internal failed for hci0:12 with -EEXIST, don't try to register things with the same name in the same directory.
Oct 22 13:23:25 worklap kernel: Modules linked in: tun fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack rfcom
Oct 22 13:23:25 worklap kernel:  sdhci mmc_core bluetooth tpm_tis tpm_infineon rfkill lpc_ich mfd_core mperf hp_accel lis3lv02d input_polldev snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore tpm tpm_bios shpchp e1000e mei_me mei ptp pps_core wmi uinput i915 firewire_ohci i2c_algo_bit drm_kms_helper firewire_core drm crc_itu_t i2c_core video
Oct 22 13:23:25 worklap kernel: CPU: 2 PID: 300 Comm: kworker/u17:0 Tainted: G        W    3.11.4-201.fc19.x86_64 #1
Oct 22 13:23:25 worklap kernel: Hardware name: Hewlett-Packard HP EliteBook 2760p/162A, BIOS 68SOU Ver. F.22 01/05/2012
Oct 22 13:23:25 worklap kernel: Workqueue: hci0 hci_rx_work [bluetooth]
Oct 22 13:23:25 worklap kernel:  0000000000000009 ffff88022a711b20 ffffffff8164783f ffff88022a711b68
Oct 22 13:23:25 worklap kernel:  ffff88022a711b58 ffffffff8106715d ffff8801ffeac1c8 00000000ffffffef
Oct 22 13:23:25 worklap kernel:  0000000000000000 ffff880231cc4a38 ffff8801ffeac000 ffff88022a711bb8
Oct 22 13:23:25 worklap kernel: Call Trace:
Oct 22 13:23:25 worklap kernel:  [<ffffffff8164783f>] dump_stack+0x45/0x56
Oct 22 13:23:25 worklap kernel:  [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
Oct 22 13:23:25 worklap kernel:  [<ffffffff810671cc>] warn_slowpath_fmt+0x4c/0x50
Oct 22 13:23:25 worklap kernel:  [<ffffffff812fcd74>] kobject_add_internal+0x1e4/0x2f0
Oct 22 13:23:25 worklap kernel:  [<ffffffff812fd115>] kobject_add+0x65/0xb0
Oct 22 13:23:25 worklap kernel:  [<ffffffff8118da0e>] ? kfree+0x13e/0x180
Oct 22 13:23:25 worklap kernel:  [<ffffffff813eebc5>] device_add+0x125/0x7a0
Oct 22 13:23:25 worklap kernel:  [<ffffffff813ed327>] ? dev_set_name+0x47/0x50
Oct 22 13:23:25 worklap kernel:  [<ffffffffa03a357e>] hci_conn_add_sysfs+0x4e/0xd0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffffa03970dc>] hci_event_packet+0x186c/0x2ea0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffff8109ef67>] ? dequeue_entity+0x107/0x520
Oct 22 13:23:25 worklap kernel:  [<ffffffff8109f8ce>] ? dequeue_task_fair+0x41e/0x620
Oct 22 13:23:25 worklap kernel:  [<ffffffffa0387cb8>] hci_rx_work+0x1b8/0x3c0 [bluetooth]
Oct 22 13:23:25 worklap kernel:  [<ffffffff810810d5>] process_one_work+0x175/0x430
Comment 6 Justin M. Forbes 2014-01-03 17:05:12 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 7 Samuel Sieb 2014-01-03 18:20:10 EST
I was going to comment on this, but I kept forgetting.  It seems to have been fixed with a kernel update at some point.

Note You need to log in before you can comment on or make changes to this bug.