Bug 1008132 - gc-devel BuildRequires should be bumped to >=7.2
gc-devel BuildRequires should be bumped to >=7.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 23:16 EDT by Justin Dearing
Modified: 2013-09-16 03:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 03:33:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Dearing 2013-09-14 23:16:46 EDT
I attempted to build the RawHide rpm on a highly modified CentOS 6.4 with the stock 7.1 gc-devel and got the error below. Rebuilding the gc srpm from Rawhide and installing the resulting gc-devel fixed it.



make[1]: Leaving directory `/home/mono/rpmbuild/BUILD/w3m-0.5.3/libwc'
gcc  -I. -I. -O2 -g -I./libwc    -DHAVE_CONFIG_H -DAUXBIN_DIR=\"/usr/libexec/w3m\" -DCGIBIN_DIR=\"/usr/libexec/w3m/cgi-bin\" -DHELP_DIR=\"/usr/share/w3m\" -DETC_DIR=\"/etc\" -DCONF_DIR=\"/etc/w3m\" -DRC_DIR=\"~/.w3m\" -DLOCALEDIR=\"/usr/share/locale\" -o w3m main.o file.o buffer.o display.o etc.o search.o linein.o table.o local.o form.o map.o frame.o rc.o menu.o mailcap.o image.o symbol.o entity.o terms.o url.o ftp.o mimehead.o regex.o news.o func.o cookie.o history.o backend.o keybind.o anchor.o parsetagx.o tagtable.o istream.o version.o  -lm  -lbsd -lnsl -ldl -L. -lindep  -lgc -L./libwc -lwc -Wl,-z,relro -lssl -lcrypto -ldl -lz   -lssl -lcrypto -lgpm -lncurses
main.o: In function `main':
/home/mono/rpmbuild/BUILD/w3m-0.5.3/main.c:836: undefined reference to `GC_get_warn_proc'
collect2: ld returned 1 exit status
make: *** [w3m] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.4GlPkm (%build)
Comment 1 Parag Nemade 2013-09-14 23:56:55 EDT
I am confused what are you actually trying to do? I can see recent w3m packages in Fedora are already built against gc-7.2d

Can you give steps to reproduce your problem on Fedora?
Comment 2 Justin Dearing 2013-09-15 08:05:18 EDT
I was trying to build the RPM against gc 7.1 on CentOS 6.4 and I got an error in the compilation step. I want the BuildRequires directive in the spec to cause a version error to occur as soon as rpmbuild is invoked.

If still you wish for me to go through the exercise of creating a CentOS vm, installing an older gc-7.1 RPM and them attempting to build w3m to get the same error as I got on CentOS, I will gladly do so. Let me know.
Comment 3 Parag Nemade 2013-09-16 03:33:34 EDT
CentOS bugs should be reported to http://bugs.centos.org/main_page.php

Note You need to log in before you can comment on or make changes to this bug.