Bug 1008155 - evince dies if I try to print some single page or some page range of a PDF file
evince dies if I try to print some single page or some page range of a PDF file
Status: CLOSED DUPLICATE of bug 1008335
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 06:02 EDT by Joachim Backes
Modified: 2013-09-16 04:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 04:07:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-09-15 06:02:25 EDT
Description of problem:

I open some PDF file with evince, and I try to print a single page or a pange range to some printer, but nothing is printed, and evince dies with segmentation fault:

brk(0x20b3000)                          = 0x20b3000
brk(0)                                  = 0x20b3000
brk(0x20dc000)                          = 0x20dc000
write(21, "%PDF-1.5\n%\265\355\256\373\n3 0 obj\n<< /Lengt"..., 1128) = 1128
recvfrom(7, 0x17e0354, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=7, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
recvfrom(7, 0x17e0354, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=7, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x8} ---
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault (core dumped)

Version-Release number of selected component (if applicable):

evince-3.8.2-1.fc19.x86_64

How reproducible:

always
Steps to Reproduce:
1.evince <PDF-file>
2.print a page range (or a single page)
3.

Actual results:
evince dies

Expected results:


Additional info:
Printing ok if I print the whole file
Comment 1 Joachim Backes 2013-09-16 04:07:55 EDT

*** This bug has been marked as a duplicate of bug 1008335 ***

Note You need to log in before you can comment on or make changes to this bug.