Bug 1008162 - [engine-backend] [external-provider] [glance] engine does not show RHOS public images when configuring glance as an external provider without authentication
[engine-backend] [external-provider] [glance] engine does not show RHOS publi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Federico Simoncelli
Elad
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 07:09 EDT by Elad
Modified: 2016-02-10 14:48 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshots (36.20 KB, application/x-gzip)
2013-09-15 07:09 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-09-15 07:09:29 EDT
Created attachment 797878 [details]
logs and screenshots

Description of problem:
RHEVM should show RHOS public images when importing glance as an external provider to RHEVM without authentication. 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.19.master.el6ev.noarch (is13)


How reproducible:
100%

Steps to Reproduce:
1. have a RHOS env. with public images on it and glance installed
2. add a glance images external provider to RHEVM  with no authentication


Actual results:
We cannot see the public images

Expected results:
We should see only the public images

Additional info: logs and screenshots
Comment 1 Itamar Heim 2013-09-16 01:57:09 EDT
does glance let you see public images without authentication?
Comment 2 Elad 2013-09-16 09:28:56 EDT
(In reply to Itamar Heim from comment #1)
> does glance let you see public images without authentication?

They should be exposed to RHEVM without authentication
Comment 3 Federico Simoncelli 2013-09-18 10:55:44 EDT
The problem here is the glance server configuration.

If you want to see public images without any authentication whatsoever you need to disable the keystone authentication.

Moving to ON_QA. To verify this you can either:

- try to see a public image from a different tenant
- reconfigure your server without keystone authentication (and you'll see public images as well, but without authentication)
Comment 4 Elad 2013-09-23 08:32:27 EDT
(In reply to Federico Simoncelli from comment #3)
> The problem here is the glance server configuration.
> 
> If you want to see public images without any authentication whatsoever you
> need to disable the keystone authentication.
> 
> Moving to ON_QA. To verify this you can either:
> 
> - try to see a public image from a different tenant
From a different tenant, I see the public images only when authentication is specified on rhevm
Should I be able to see them also when authentication is not specified on rhevm?
Comment 5 Federico Simoncelli 2013-10-14 12:50:56 EDT
(In reply to Elad from comment #4)
> (In reply to Federico Simoncelli from comment #3)
> > The problem here is the glance server configuration.
> > 
> > If you want to see public images without any authentication whatsoever you
> > need to disable the keystone authentication.
> > 
> > Moving to ON_QA. To verify this you can either:
> > 
> > - try to see a public image from a different tenant
> From a different tenant, I see the public images only when authentication is
> specified on rhevm
> Should I be able to see them also when authentication is not specified on
> rhevm?

No, because no-authentication in the rhevm provider definition means no-authentication on glance as well, and no-authentication on glance means that you're not using the keystone auth flavor at all.
Comment 6 Elad 2013-10-15 03:26:24 EDT
Using RHEVM, public images are shown when using a different tenant.

Verified with RHEVM3.3 is18
Comment 7 Itamar Heim 2014-01-21 17:30:34 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:30:35 EST
Closing - RHEV 3.3 Released
Comment 9 Itamar Heim 2014-01-21 17:33:35 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.