Bug 1008240 - Vm fails to migrate when migration host don't meet with network requirments.
Vm fails to migrate when migration host don't meet with network requirments.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Noam Slomianko
Lukas Svaty
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 16:36 EDT by Ondra Machacek
Modified: 2016-02-10 15:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 08:50:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (37.04 KB, text/plain)
2013-09-15 16:36 EDT, Ondra Machacek
no flags Details

  None (edit)
Description Ondra Machacek 2013-09-15 16:36:55 EDT
Created attachment 798029 [details]
engine.log

Description of problem:


Version-Release number of selected component (if applicable):
is13

How reproducible:
always

Steps to Reproduce:
0. Create cluster with 2hosts and network filter as cluster policy.
1. Create non-required network.
2. Assign this network to host1.
3. Create vm with vnic with non-required network.
4. Run this vm.
5. Migrate vm.

Actual results:
Vm starts on host1, but migration fails. (vm is down, when try to run,
engine says vm is migrating, could not run.)

Expected results:
Not possible to migrate vm.

Additional info:
Comment 1 Doron Fediuck 2013-09-16 05:06:38 EDT
Hi Ondra,
Can you please specify what your policy was made of?
ie- which filters, weight module and balancing?
Comment 2 Ondra Machacek 2013-09-16 07:49:50 EDT
I used only network filter as filter, none weigh and none balancing.
Comment 3 Noam Slomianko 2013-09-24 10:58:58 EDT
Could not reproduce, I got:
"Cannot migrate VM. There are no available running Hosts with all the networks used by the VM."
as expected.


my set up was:
host1 - 2 nics, one is the non required
host2 - 1 nic, only ovirtmgmt
vm1 - 1 nic with non required network as profile


Do you have an environment where this reproduces?
Comment 4 Ondra Machacek 2013-10-07 07:07:19 EDT
I couldn't reproduce it on is17. Vm is not possible to migrate on host
which don't have needed network.

But different problem appears:

When there is exactly same setup, but only network filter is not used, then
vm is not possible to migrate on host which don't have needed network.

Steps to Reproduce:
1. Create cluster with 2hosts.
2. Create cluster policy with only memory filter.
3. Assign this policy to cluster with hosts.
4. Create non-required network.
5. Assign this network to host1.
6. Create vm with vnic with non-required network.
7. Run this vm.
8. Migrate vm.

Actual results:
Not possible to migrate vm on host without non-required network.

Expected results:
Possible to migrate vm, because network filter is not used.
Comment 5 Ondra Machacek 2013-10-16 08:55:30 EDT
Because bug which was originally reported is OK, new bug 1019812 was opened.

Note You need to log in before you can comment on or make changes to this bug.