Bug 1008276 - [abrt] rhythmbox-2.99.1-1.fc19: g_assertion_message: Process /usr/bin/rhythmbox was killed by signal 6 (SIGABRT)
[abrt] rhythmbox-2.99.1-1.fc19: g_assertion_message: Process /usr/bin/rhythmb...
Status: CLOSED DUPLICATE of bug 951845
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:d7e9cf18afbb3cffc5c04dbc434...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 00:35 EDT by Charles R. Anderson
Modified: 2014-05-24 15:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 09:36:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.65 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: cgroup (141 bytes, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: core_backtrace (47.87 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: dso_list (28.45 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: environ (1.79 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: maps (131.12 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: open_fds (1.82 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: proc_pid_status (949 bytes, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details
File: var_log_messages (6.31 KB, text/plain)
2013-09-16 00:35 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2013-09-16 00:35:04 EDT
Description of problem:
Scan music library, enable shuffle, play files.  It got stuck on .mid files and I was unable to get it to skip to the next file in shuffle order--it just stopped playing, and the "next track" button was greyed out.  I clicked "play" again multiple times to try to get "next track" enabled and then this crash happened.

Version-Release number of selected component:
rhythmbox-2.99.1-1.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: g_assertion_message
executable:     /usr/bin/rhythmbox
kernel:         3.10.11-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            10002

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_assertion_message at /lib64/libglib-2.0.so.0
 #3 g_assertion_message_expr at /lib64/libglib-2.0.so.0
 #4 g_base_info_get_name at /lib64/libgirepository-1.0.so.1
 #5 _pygi_closure_handle at /usr/lib64/python2.7/site-packages/gi/_gi.so
 #6 ffi_closure_unix64_inner at /lib64/libffi.so.6
 #7 ffi_closure_unix64 at /lib64/libffi.so.6
 #8 gst_pad_add_probe at /lib64/libgstreamer-1.0.so.0
 #9 ffi_call_unix64 at /lib64/libffi.so.6
 #10 ffi_call at /lib64/libffi.so.6
 #11 g_callable_info_invoke at /lib64/libgirepository-1.0.so.1
Comment 1 Charles R. Anderson 2013-09-16 00:35:08 EDT
Created attachment 798091 [details]
File: backtrace
Comment 2 Charles R. Anderson 2013-09-16 00:35:10 EDT
Created attachment 798092 [details]
File: cgroup
Comment 3 Charles R. Anderson 2013-09-16 00:35:13 EDT
Created attachment 798093 [details]
File: core_backtrace
Comment 4 Charles R. Anderson 2013-09-16 00:35:17 EDT
Created attachment 798094 [details]
File: dso_list
Comment 5 Charles R. Anderson 2013-09-16 00:35:20 EDT
Created attachment 798095 [details]
File: environ
Comment 6 Charles R. Anderson 2013-09-16 00:35:22 EDT
Created attachment 798096 [details]
File: limits
Comment 7 Charles R. Anderson 2013-09-16 00:35:25 EDT
Created attachment 798097 [details]
File: maps
Comment 8 Charles R. Anderson 2013-09-16 00:35:27 EDT
Created attachment 798098 [details]
File: open_fds
Comment 9 Charles R. Anderson 2013-09-16 00:35:30 EDT
Created attachment 798099 [details]
File: proc_pid_status
Comment 10 Charles R. Anderson 2013-09-16 00:35:32 EDT
Created attachment 798100 [details]
File: var_log_messages
Comment 11 Charles R. Anderson 2013-09-16 01:04:42 EDT
I think the .mid file issue is a red herring.  This crash is happening every time the track is advanced to the next song even when using an automatic playlist that excludes midi files.  The first song plays fine without crashing, then this crash happens when the track changes, every time.  After disabling the following plugins, this crash no longer happens, so it appears to be at least one of these plugins causing the issue:

Context Pane
Last.fm
ReplayGain
Song Lyrics
Comment 12 balamahendran 2013-10-22 15:55:54 EDT
When I Enable Reply gain from plugins  and played two three songs(.mp3) and i presses next button .. suddenly player closed... and reported bug took me to this page Thank You...
Comment 13 Felix Schwarz 2013-11-11 08:35:12 EST
this looks like a duplicate of bug 941845
Comment 14 Charles R. Anderson 2013-11-11 09:12:46 EST
(In reply to Felix Schwarz from comment #13)
> this looks like a duplicate of bug 941845

That bug is set to private so normal people can't view it.
Comment 15 Felix Schwarz 2013-11-11 09:25:00 EST
That is stran(In reply to Charles R. Anderson from comment #14)
> That bug is set to private so normal people can't view it.

Strange - it wasn't private a few minutes ago.
Comment 16 Felix Schwarz 2013-11-11 09:25:49 EST
actually I messed up the bug reference: bug 951845 is what I meant.
Comment 17 Charles R. Anderson 2013-11-11 09:36:24 EST
Agreed that this is a duplicate.   Thanks.

*** This bug has been marked as a duplicate of bug 951845 ***

Note You need to log in before you can comment on or make changes to this bug.