Bug 1008308 - Newly provisioned instance has an entry for non-existent xvdb in /etc/fstab
Newly provisioned instance has an entry for non-existent xvdb in /etc/fstab
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: ami (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 02:20 EDT by Anush Shetty
Modified: 2014-07-11 02:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2013-09-16 02:20:21 EDT
Description of problem: A newly privisoned ami instance has an entry for non-existent xvdb in /etc/fstab


# cat /etc/fstab 
LABEL=_/   /         ext4    defaults        1 1
/dev/xvdb  /mnt      ext3    defaults,context=system_u:object_r:usr_t:s0  0 0
none       /proc     proc    defaults        0 0
none       /sys      sysfs   defaults        0 0
none       /dev/pts  devpts  gid=5,mode=620  0 0
none       /dev/shm  tmpfs   defaults        0 0

# mount -a
mount: special device /dev/xvdb does not exist

Version-Release number of selected component (if applicable): RHEL-6.4-RHS-2.1-x86_64-3-Access2 (ami-e488c3b6)


How reproducible: Always


Steps to Reproduce:
1.
2.
3.

Actual results:

/dev/xvdb has an entry in /etc/fstab. /dev/xvdb doesn't exist.

Expected results:

/etc/fstab shouldn't have an entry for /etc/fstab

Additional info:

# fdisk -l

Disk /dev/xvda1: 107.4 GB, 107374182400 bytes
255 heads, 63 sectors/track, 13054 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000
Comment 2 Anush Shetty 2013-09-16 02:29:20 EDT
Small correction,

Expected results:

/etc/fstab shouldn't have an entry for /dev/xvdb
Comment 3 Anush Shetty 2013-09-18 02:29:16 EDT
Verified with AMI: RHEL-6.4-RHS-2.1-x86_64-5-Access2 (ami-15470c7c)
Comment 4 Scott Haines 2013-09-23 18:29:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.