Bug 1008335 - [abrt] evince-3.8.3-2.fc19: __strlen_sse2: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
[abrt] evince-3.8.3-2.fc19: __strlen_sse2: Process /usr/bin/evince was killed...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
abrt_hash:e6a5795974c1bd82b3d54e6b4a7...
:
: 1008155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 04:00 EDT by Joachim Backes
Modified: 2014-09-10 03:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 03:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.65 KB, text/plain)
2013-09-16 04:00 EDT, Joachim Backes
no flags Details
File: cgroup (141 bytes, text/plain)
2013-09-16 04:00 EDT, Joachim Backes
no flags Details
File: core_backtrace (17.99 KB, text/plain)
2013-09-16 04:00 EDT, Joachim Backes
no flags Details
File: dso_list (11.50 KB, text/plain)
2013-09-16 04:00 EDT, Joachim Backes
no flags Details
File: environ (1.84 KB, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: maps (60.86 KB, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: open_fds (1.57 KB, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: proc_pid_status (926 bytes, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: var_log_messages (26.12 KB, text/plain)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details
File: NBS-Uebersicht.pdf (479.78 KB, application/octet-stream)
2013-09-16 04:01 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2013-09-16 04:00:28 EDT
Description of problem:
Trying to print a range of a PDF file (setting the correspondent range in the evince printer dialog). After pressing the print button, nothing is printed, and evince died (See BZ 1008155)

Version-Release number of selected component:
evince-3.8.3-2.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        evince /home/backes/Downloads/NBS-Uebersicht.pdf
crash_function: __strlen_sse2
executable:     /usr/bin/evince
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __strlen_sse2 at ../sysdeps/x86_64/strlen.S:31
 #1 write_used_glyphs at cairo-type1-subset.c:1147
 #2 cairo_type1_font_subset_for_each_glyph at cairo-type1-subset.c:1229
 #3 cairo_type1_font_subset_write_private_dict at cairo-type1-subset.c:1480
 #4 cairo_type1_font_subset_write at cairo-type1-subset.c:1587
 #5 cairo_type1_font_subset_generate at cairo-type1-subset.c:1659
 #6 _cairo_type1_subset_init at cairo-type1-subset.c:1724
 #8 _cairo_pdf_surface_emit_type1_font_subset at cairo-pdf-surface.c:5039
 #9 _cairo_pdf_surface_emit_unscaled_font_subset at cairo-pdf-surface.c:5566
 #10 _cairo_sub_font_collect at cairo-scaled-font-subsets.c:746
Comment 1 Joachim Backes 2013-09-16 04:00:36 EDT
Created attachment 798134 [details]
File: backtrace
Comment 2 Joachim Backes 2013-09-16 04:00:40 EDT
Created attachment 798135 [details]
File: cgroup
Comment 3 Joachim Backes 2013-09-16 04:00:49 EDT
Created attachment 798136 [details]
File: core_backtrace
Comment 4 Joachim Backes 2013-09-16 04:00:56 EDT
Created attachment 798137 [details]
File: dso_list
Comment 5 Joachim Backes 2013-09-16 04:01:04 EDT
Created attachment 798138 [details]
File: environ
Comment 6 Joachim Backes 2013-09-16 04:01:11 EDT
Created attachment 798139 [details]
File: limits
Comment 7 Joachim Backes 2013-09-16 04:01:15 EDT
Created attachment 798140 [details]
File: maps
Comment 8 Joachim Backes 2013-09-16 04:01:20 EDT
Created attachment 798141 [details]
File: open_fds
Comment 9 Joachim Backes 2013-09-16 04:01:24 EDT
Created attachment 798142 [details]
File: proc_pid_status
Comment 10 Joachim Backes 2013-09-16 04:01:27 EDT
Created attachment 798143 [details]
File: var_log_messages
Comment 11 Joachim Backes 2013-09-16 04:01:36 EDT
Created attachment 798144 [details]
File: NBS-Uebersicht.pdf
Comment 12 Joachim Backes 2013-09-16 04:07:55 EDT
*** Bug 1008155 has been marked as a duplicate of this bug. ***
Comment 13 Marek Kašík 2013-10-25 05:58:23 EDT
This is a cairo bug. See https://bugzilla.redhat.com/show_bug.cgi?id=957009 for additional info.
Comment 14 Joachim Backes 2014-09-10 03:47:24 EDT
can't reproduce with

cairo-1.13.1-0.1.git337ab1f.fc20.x86_64
and

evince-3.10.3-1.fc20.x86_64

Note You need to log in before you can comment on or make changes to this bug.