Bug 1008378 - Organizational Unit Manager: multiple groups for a repository
Organizational Unit Manager: multiple groups for a repository
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 05:47 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-16 05:47:53 EDT
Description of problem:
When creating or cloning a repository, you are only allowed to select one group. In the Organizational Unit Manager however, you can add a repository to multiple groups.

Please fix this inconsistency. 
I'm not 100% sure this is the cause, but when I tried to build and deploy a project in a repository with 2 groups, I got this:

ERROR [stderr] ... java.lang.NullPointerException
ERROR [stderr] ... 	at org.kie.kieora.io.BatchIndex$1.run(BatchIndex.java:59)


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3
Comment 2 Zuzana Krejčová 2013-10-31 05:33:26 EDT
Verified on ER4 - a repository can only belong to one org. unit.

Note You need to log in before you can comment on or make changes to this bug.