Bug 1008389 - When installing in Arabic, only Arabic keyboard is offered by default although the Arabic keyboard does not support ASCII
When installing in Arabic, only Arabic keyboard is offered by default althoug...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: langtable (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 06:00 EDT by Mike FABIAN
Modified: 2014-01-21 00:57 EST (History)
5 users (show)

See Also:
Fixed In Version: langtable-0.0.23-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 00:57:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
keyboards-default-russian-compared-with-arabic.png (101.18 KB, image/png)
2013-09-16 06:00 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-09-16 06:00:04 EDT
Created attachment 798197 [details]
keyboards-default-russian-compared-with-arabic.png

Fedora-20-Alpha-RC2-x86_64-netinst.iso

Select Arabic in the first screen and continue.

Click on the keyboard setup button near the top right.

See that only one keyboard is available (Arabic, ara), although
this does not support ASCII.

For other languages like Russian, where a keyboard is
selected by default which does not support ASCII, US English
keyboard is added automatically as a second keyboard.
Comment 1 Parag Nemade 2013-09-16 07:58:54 EDT
I guess this can be then anaconda bug and not langtable right?
Comment 2 Mike FABIAN 2013-09-16 11:27:31 EDT
At the moment I believe this to be a langtable bug because 
langtable fails to have the proper information about the "ara"
keyboard layout. 

langtable suggests "ara" as the default keyboard for ar_EG.UTF-8 locale
but then does not have any information about "ara", so anaconda
cannot tell whether "ara" supports ASCII or not.
Comment 3 Fedora Update System 2013-09-16 13:45:13 EDT
langtable-0.0.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.15-1.fc19
Comment 4 Fedora Update System 2013-09-16 13:49:00 EDT
langtable-0.0.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/langtable-0.0.15-1.fc20
Comment 5 Fedora Update System 2013-09-17 14:14:57 EDT
Package langtable-0.0.15-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing langtable-0.0.15-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16949/langtable-0.0.15-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-09-28 21:45:36 EDT
langtable-0.0.15-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Mike FABIAN 2013-10-07 02:05:00 EDT
Works in Fedora 20 Beta TC1.
Comment 8 Fedora Update System 2013-10-08 07:32:45 EDT
langtable-0.0.16-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.16-1.fc19
Comment 9 Fedora Update System 2013-10-09 20:51:48 EDT
Package langtable-0.0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing langtable-0.0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18596/langtable-0.0.16-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-22 10:22:45 EDT
langtable-0.0.17-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.17-1.fc19
Comment 11 Fedora Update System 2013-11-04 07:18:00 EST
langtable-0.0.18-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.18-1.fc19
Comment 12 Parag Nemade 2013-11-04 09:00:14 EST
There is no need to add this bug as a reference to newer langtable releases as langtable-0.0.15 is already in main f20 repo.
Comment 13 Fedora Update System 2013-11-11 12:09:24 EST
langtable-0.0.19-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.19-1.fc19
Comment 14 Fedora Update System 2013-11-19 18:45:34 EST
langtable-0.0.20-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.20-1.fc19
Comment 15 Fedora Update System 2013-12-04 09:39:35 EST
langtable-0.0.22-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.22-1.fc19
Comment 16 Fedora Update System 2013-12-10 11:58:48 EST
langtable-0.0.23-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.23-1.fc19
Comment 17 Fedora Update System 2014-01-21 00:57:17 EST
langtable-0.0.23-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.