Bug 1008431 - crash [@ Oxygen::draw_box]
crash [@ Oxygen::draw_box]
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: oxygen-gtk2 (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:f581925c86f3d048ec2b3be897c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 07:08 EDT by Paulo Fidalgo
Modified: 2014-01-29 22:34 EST (History)
8 users (show)

See Also:
Fixed In Version: oxygen-gtk2-1.4.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 22:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (98.31 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: core_backtrace (80.65 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: dso_list (12.04 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: environ (1.58 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: maps (60.50 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: open_fds (2.52 KB, text/plain)
2013-09-16 07:08 EDT, Paulo Fidalgo
no flags Details
File: proc_pid_status (938 bytes, text/plain)
2013-09-16 07:09 EDT, Paulo Fidalgo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 325815 None None None Never

  None (edit)
Description Paulo Fidalgo 2013-09-16 07:08:12 EDT
Description of problem:
I've just started the Pencil application, after install.

Version-Release number of selected component:
xulrunner-23.0.1-4.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/lib64/xulrunner/xulrunner --app /usr/share/pencil/application.ini
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/xulrunner/xulrunner
kernel:         3.10.11-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: Sep 16 11:27:31 localhost abrt[9445]: Saved core dump of pid 9412 (/usr/lib64/xulrunner/xulrunner) to /var/tmp/abrt/ccpp-2013-09-16-11:27:29-9412 (290811904 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 nsProfileLock::FatalSignalHandler at /usr/src/debug/xulrunner-23.0.1/mozilla-release/objdir/toolkit/profile/nsProfileLock.cpp:180
 #3 mozalloc_abort at /usr/src/debug/xulrunner-23.0.1/mozilla-release/memory/mozalloc/mozalloc_abort.cpp:30
 #4 Abort at /usr/src/debug/xulrunner-23.0.1/mozilla-release/xpcom/base/nsDebugImpl.cpp:430
 #5 NS_DebugBreak at /usr/src/debug/xulrunner-23.0.1/mozilla-release/xpcom/base/nsDebugImpl.cpp:417
 #6 X11Error at /usr/src/debug/xulrunner-23.0.1/mozilla-release/toolkit/xre/nsX11ErrorHandler.cpp:157
 #8 handle_error at xcb_io.c:213
 #9 handle_response at xcb_io.c:325
 #11 XShapeGetRectangles at XShape.c:457
 #12 _xwindow_get_shape at gdkwindow-x11.c:4687
 #13 _gdk_windowing_get_shape_for_mask at gdkwindow-x11.c:4739
Comment 1 Paulo Fidalgo 2013-09-16 07:08:22 EDT
Created attachment 798229 [details]
File: backtrace
Comment 2 Paulo Fidalgo 2013-09-16 07:08:26 EDT
Created attachment 798230 [details]
File: cgroup
Comment 3 Paulo Fidalgo 2013-09-16 07:08:33 EDT
Created attachment 798231 [details]
File: core_backtrace
Comment 4 Paulo Fidalgo 2013-09-16 07:08:37 EDT
Created attachment 798232 [details]
File: dso_list
Comment 5 Paulo Fidalgo 2013-09-16 07:08:42 EDT
Created attachment 798233 [details]
File: environ
Comment 6 Paulo Fidalgo 2013-09-16 07:08:46 EDT
Created attachment 798234 [details]
File: limits
Comment 7 Paulo Fidalgo 2013-09-16 07:08:51 EDT
Created attachment 798235 [details]
File: maps
Comment 8 Paulo Fidalgo 2013-09-16 07:08:57 EDT
Created attachment 798236 [details]
File: open_fds
Comment 9 Paulo Fidalgo 2013-09-16 07:09:01 EDT
Created attachment 798237 [details]
File: proc_pid_status
Comment 10 Paulo Fidalgo 2013-09-16 07:23:51 EDT
This happens every time I try to click in the menu bar.
Comment 11 Anton 2013-10-08 12:57:20 EDT
Just press "Document" menu

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/lib64/xulrunner/xulrunner --app /usr/share/pencil/application.ini
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/xulrunner/xulrunner
kernel:         3.11.3-201.fc19.x86_64
package:        xulrunner-24.0-2.fc19
reason:         Process /usr/lib64/xulrunner/xulrunner was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 12 Martin Stransky 2013-10-09 06:08:16 EDT
Looks like the crash comes from Oxygen theme. Moving. Just for check, can you test the default theme - Adwaita?


#17 Oxygen::draw_box (style=0x7fa9a47cafd0, window=0x7fa96ccaf800, state=GTK_STATE_NORMAL, shadow=<optimized out>, clipRect=0x7fffc72ee740, widget=0x7fa9a48f83d0, detail=0x37e6201439 "menu", x=0, y=0, w=93, h=32) at /usr/src/debug/oxygen-gtk2-1.4.0/src/oxygenstylewrapper.cpp:1261
        options = {<Oxygen::Flags<Oxygen::StyleOption>> = {_vptr.Flags = 0x7fa9a13f8150 <vtable for Oxygen::StyleOptions+16>, i = 8704}, _customColors = {<std::map<Oxygen::Palette::Role, Oxygen::ColorUtils::Rgba, std::less<Oxygen::Palette::Role>, std::allocator<std::pair<Oxygen::Palette::Role const, Oxygen::ColorUtils::Rgba> > >> = std::map with 1 elements = {[Oxygen::Palette::Window] = {_red = 54998, _green = 53970, _blue = 53456, _alpha = 65535, _mask = 15}}, <No data fields>}}
        __PRETTY_FUNCTION__ = "void Oxygen::draw_box(GtkStyle*, GdkWindow*, GtkStateType, GtkShadowType, GdkRectangle*, GtkWidget*, const gchar*, gint, gint, gint, gint)"
        d = {_value = "menu"}
        parent = 0x0

#18 0x00000037e58b5c1c in moz_gtk_menu_separator_paint (direction=<optimized out>, cliprect=<optimized out>, rect=<optimized out>, drawable=<optimized
Comment 13 Paulo Fidalgo 2013-10-09 06:21:48 EDT
Yes, the problem is with oxygen-gtk. Changing to Adwaita theme it works normally.
Comment 14 Rex Dieter 2013-10-11 08:02:48 EDT
rpm -q pencil oxygen-gtk2 xulrunner

please.


testing on f20 with,

pencil-2.0.4-3.fc20.noarch
oxygen-gtk2-1.4.0-1.fc20.x86_64
xulrunner-24.0-2.fc20.x86_64

pencil seems to startup ok for me.
Comment 15 Paulo Fidalgo 2013-10-11 08:39:06 EDT
pencil-2.0.4-2.fc19.noarch
oxygen-gtk2-1.4.0-1.fc19.x86_64
xulrunner-24.0-2.fc19.x86_64
Comment 16 Fedora Update System 2014-01-20 17:36:38 EST
oxygen-gtk2-1.4.2-1.fc19,oxygen-gtk3-1.2.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/oxygen-gtk2-1.4.2-1.fc19,oxygen-gtk3-1.2.2-1.fc19
Comment 17 Fedora Update System 2014-01-20 21:32:52 EST
oxygen-gtk2-1.4.2-1.fc20, oxygen-gtk3-1.3.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/oxygen-gtk2-1.4.2-1.fc20,oxygen-gtk3-1.3.2-1.fc20
Comment 18 Fedora Update System 2014-01-21 22:07:06 EST
oxygen-gtk2-1.4.2-1.fc20, oxygen-gtk3-1.3.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2014-01-29 22:34:59 EST
oxygen-gtk2-1.4.2-1.fc19, oxygen-gtk3-1.2.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.