Bug 1008487 - [glance] there is no timeout failure in case image upload fails and image gets stuck in 'queued' state
[glance] there is no timeout failure in case image upload fails and image get...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 4.0
Assigned To: Flavio Percoco
Haim
storage
:
: 1010633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:11 EDT by Elad
Modified: 2016-04-26 09:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 09:53:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (377.28 KB, application/x-gzip)
2013-09-16 09:11 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-09-16 09:11:29 EDT
Created attachment 798280 [details]
logs

Description of problem:
Exporting a disk from RHEV to glance when vdsm hypervisor is blocked from glance in port 9292, is causing the exported image to stuck in 'queued' state in glance forever.

Version-Release number of selected component (if applicable):
openstack-glance-2013.1.3-1.el6ost.noarch

How reproducible:
100%

Steps to Reproduce:
With open-stack (glance installed) and RHEV environments  
1. add glance to RHEVM as an external provider
2. create new disk in RHEV
3. block connectivity from vdsm hypervisor to openstack-glance host in port 9292
4. export the disk from RHEV to glance

Actual results:
image gets stuck in 'queued' state 

| e9e3c9c0-13d2-4844-acca-17fba1a2862a | iscsi1-2       | raw         | bare             |            | queued |


Expected results:
glance should fail this task and delete the image

Additional info: logs
Comment 1 Elad 2013-09-16 09:14:59 EDT
Version-Release number of selected component (if applicable):
openstack-glance-2013.1.3-1.el6ost.noarch
rhevm-3.3.0-0.19.master.el6ev.noarch
vdsm-4.12.0-127.gitedb88bf.el6ev.x86_64
Comment 2 Dafna Ron 2013-10-01 10:48:56 EDT
*** Bug 1010633 has been marked as a duplicate of this bug. ***
Comment 3 Dafna Ron 2013-10-01 10:50:56 EDT
Elad, please make sure to run scenario from bug below as well when this bug is fixed. 
https://bugzilla.redhat.com/show_bug.cgi?id=1010633
Comment 4 Flavio Percoco 2013-10-08 06:16:47 EDT
In glance, image records are separate from image data. When an image upload fails, the uploaded data is cleaned but the record is kept because you can still upload data for that image. Also, it was recently added support for multiple locations which means that an 1 image record can store its data in different locations.

Could you verify the partially uploaded data is cleaned up? If so, I'll close this bug as 'NOTABUG'.
Comment 5 Elad 2013-10-17 06:40:35 EDT
(In reply to Flavio Percoco from comment #4)
> In glance, image records are separate from image data. When an image upload
> fails, the uploaded data is cleaned but the record is kept because you can
> still upload data for that image. Also, it was recently added support for
> multiple locations which means that an 1 image record can store its data in
> different locations.
> 
> Could you verify the partially uploaded data is cleaned up? If so, I'll
> close this bug as 'NOTABUG'.
This is happening indeed.

The image is no longer existing under /var/lib/glance/images/
Comment 6 Flavio Percoco 2013-11-13 09:53:28 EST
Thanks for double-checking, I'll close this bug!

Note You need to log in before you can comment on or make changes to this bug.