Bug 1008544 - NetworkUser can't see all networks when he has system permissions.
NetworkUser can't see all networks when he has system permissions.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.2.4
Assigned To: Moti Asayag
GenadiC
network
: Reopened, ZStream
Depends On: 1004227
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 10:55 EDT by rhev-integ
Modified: 2016-02-10 14:48 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A user with a system-wide NetworkUser role can now correctly view all the networks in the system.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 14:44:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rhev-integ 2013-09-16 10:55:33 EDT
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=1004227. +++

======================================================================



----------------------------------------------------------------------
Following comment by omachace@redhat.com on September 04 at 08:53:18, 2013

Description of problem:
When User has NetworkUser role on system, then he can't see all networks in
system. He can only see networks which are attached to cluster, and to vnic.

Version-Release number of selected component (if applicable):
sf20

How reproducible:
always

Steps to Reproduce:
1. Create 2 networks, network1 and network2.
2. Attach network1 to cluster.
3. Create vm and add vnic to this vm with network1.
4. Add user and add him NetworkUser role on system.
5. As user check /api/networks

Actual results:
User can see only network1, and he can't see network2.

Expected results:
User can see both networks.

Additional info:

----------------------------------------------------------------------
Following comment by danken@redhat.com on September 16 at 12:17:17, 2013

(01:11:51 PM) masayag: https://bugzilla.redhat.com/show_bug.cgi?id=1004227 should be cloned for Z-stream and be closed on 3.3 as CURRENT_RELEASE
(01:12:30 PM) masayag: it is relevant only for 3.2 since there we used to have permissions on network while on 3.3 we set the user permissions on the vnic profiles

----------------------------------------------------------------------
Following comment by aberezin@redhat.com on September 16 at 12:44:24, 2013

Is same behaviour experienced in UI?

----------------------------------------------------------------------
Following comment by italkohe@redhat.com on September 16 at 14:52:53, 2013

Changing bug status in order to clone it to 3.2.4.
Comment 2 GenadiC 2013-10-13 04:01:19 EDT
Verified on rhevm-3.2.4-0.44.el6ev.noarch
Comment 4 errata-xmlrpc 2013-10-25 14:44:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1468.html

Note You need to log in before you can comment on or make changes to this bug.