Bug 1008549 - Missing javadoc for org.jboss.as.controller-client
Missing javadoc for org.jboss.as.controller-client
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER6
: EAP 6.2.0
Assigned To: Yong Yang
Jakub Cechacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 10:58 EDT by Jakub Cechacek
Modified: 2015-02-01 18:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-09-16 10:58:53 EDT
Current javadoc is missing documentation for following jars and packages 

/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/jboss/as/controller-client/main/jboss-as-controller-client-7.3.0.Final-redhat-1.jar
7 missing:
   org.jboss.as.controller.client
   org.jboss.as.controller.client.helpers.standalone
   org.jboss.as.controller.client.helpers.standalone.impl
   org.jboss.as.controller.client.helpers
   org.jboss.as.controller.client.helpers.domain
   org.jboss.as.controller.client.helpers.domain.impl
   org.jboss.as.controller.client.impl
Comment 1 Misty Stanley-Jones 2013-10-09 23:16:58 EDT
I'm not sure what the right component is for Javadoc bugs, but Documentation should be used for formal documentation maintained by Content Services. Javadoc does not fall under this category. Maybe we need a new component for it?
Comment 2 Yong Yang 2013-10-12 04:13:28 EDT
This artifact was excluded from javadoc generation before 6.2.0 due to some error. Now it has been fixed in Jenkins, https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/EAP6-javadoc/75/, and will be included in next ER. 


FYI:
$ cat build/javadoc/artifactsBlacklist.txt 
org.jboss.as:jboss-as-controller-client
org.jboss:jboss-dmr
org.jboss.jbossts:jbossxts
org.jboss.jbossts:jbossxts-api
org.jboss.weld:weld-core
org.picketbox:picketbox-commons
xalan:serializer
org.apache.ws.security:wss4j
Comment 3 Yong Yang 2013-10-18 06:26:22 EDT
These javadocs are generated in EAP6.2.0 ER6.
Comment 4 Jakub Cechacek 2013-10-22 03:43:18 EDT
verified 6.2.0.ER6

Note You need to log in before you can comment on or make changes to this bug.