This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008550 - Missing javadoc for org.jboss.dmr
Missing javadoc for org.jboss.dmr
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.2.0
Assigned To: Yong Yang
Jakub Cechacek
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 10:58 EDT by Jakub Cechacek
Modified: 2015-02-20 05:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:23:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-09-16 10:58:56 EDT
Current javadoc is missing documentation for following jars and packages 

/home/jcechace/tools/eap/eap6/620/jboss-eap-6.2/modules/system/layers/base/org/jboss/dmr/main/jboss-dmr-1.2.0.Final.jar
1 missing:
   org.jboss.dmr
Comment 1 Aleksandar Kostadinov 2013-09-17 10:48:50 EDT
FYI all javadoc from RPM distro come from one package, currently:
> jbossas-javadocs-7.2.1-2.Final_redhat_10.ep6.el6.noarch.rpm

Only jboss-dmr javadocs come bundled with the library RPM:
> # yum whatprovides /usr/share/javadoc/jboss-dmr-1.1.6.Final-redhat-1/
> ...
> jboss-dmr-1.1.6-1.Final_redhat_1.ep6.el6.noarch

As you can see by the path above, the javadoc is in a separate root, disintegrated from the main javadoc RPM.

So it seems like RPMs are also affected by this discrepancy and it would be needed to move javadoc to the appropriate place.
Comment 2 Misty Stanley-Jones 2013-10-09 23:16:57 EDT
I'm not sure what the right component is for Javadoc bugs, but Documentation should be used for formal documentation maintained by Content Services. Javadoc does not fall under this category. Maybe we need a new component for it?
Comment 3 Yong Yang 2013-10-12 04:14:20 EDT
This artifact was excluded from javadoc generation before 6.2.0 due to some error. Now it has been fixed in Jenkins, https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/EAP6-javadoc/75/, and will be included in next ER. 


FYI:
$ cat build/javadoc/artifactsBlacklist.txt 
org.jboss.as:jboss-as-controller-client
org.jboss:jboss-dmr
org.jboss.jbossts:jbossxts
org.jboss.jbossts:jbossxts-api
org.jboss.weld:weld-core
org.picketbox:picketbox-commons
xalan:serializer
org.apache.ws.security:wss4j
Comment 4 Yong Yang 2013-10-18 06:25:50 EDT
These javadocs are generated in EAP6.2.0 ER6.
Comment 5 Jakub Cechacek 2013-10-22 03:43:57 EDT
verified 6.2.0.ER6
Comment 6 Pavel Janousek 2013-11-04 04:50:32 EST
DMR JavaDoc in RPM based installation is still distributed separately of the rest of JavaDocs as Aleksandar complained in comment #1.

Couldn't be verified in ER6 because ER6's RPM weren't hand over to QE.
Comment 7 Yong Yang 2013-11-04 21:42:02 EST
In ER7, the version of jboss-dmr has been upgraded to 1.2.0.Final-redhat-1,
http://git.app.eng.bos.redhat.com/jbossas/jboss-as.git/tree/pom.xml?id=EAP_6.2.0.ER7#n171

And the javadocs sub-package has been removed from rpm build of this version.
Comment 8 Jakub Cechacek 2013-11-14 08:42:17 EST
Verified 6.2.0.CR1

Note You need to log in before you can comment on or make changes to this bug.